6

When I want to update packages of texlive 2015 I get this error? what is the problem?

tlmgr update --list

The locale codeset (cp720) isn't one that perl can decode, stopped at  
C:\texlive \2015\tlpkg\tlperl\lib/Encode/Locale.pm line 123. Compilation 
failed in require at C:\texlive\2015\tlpkg\tlperl\lib/LWP/UserAgent. pm 
line 1001.
  • Try first tlmgr --gui. – Sigur Jun 30 '15 at 10:55
  • @Sigur When I type tlmgr --gui I get exactly same error. – Ali Jun 30 '15 at 11:03
  • 2
    Imho you should better ask on the texlive mailing list. It sounds as if the perl script doesn't expect your code page. You could perhaps get around it by locally changing the codepage with chcp. – Ulrike Fischer Jun 30 '15 at 12:12
  • I have the same problem with my texlive 2015 on Windows 8 – Salim Bou Jun 30 '15 at 12:38
  • @Ali tlmgr --gui => tlmgr gui, the syntax changed some time ago. – Keks Dose Jun 30 '15 at 13:12
3

It seems like a bug in Texlive 2015 on windows for number of the active console code page cp720.

  • You can change this code with command prompt by inserting chcp nnn, where nnn specifies the code page ( example : chcp 850), you can find a list of cp here. but you must repeat the same steps each time you want to open tlmgr.
  • You can automate the previous steps by inserting the command chcp nnn directly in the file tlmgr.bat, in your case you can find it on this path: C:\texlive\2015\bin\win32.

    @echo off

    chcp 850

  • Thank you very much, no other solution was working. I am using windows 8.1 with strawberry perl 5.2 but still the issue was there. I was able to use Tex Live Manager 2015 by making the change you suggested. I add the chcp 850 line on the 2nd line of the file tlmgr.bat – Ibn Saeed Jan 1 '16 at 10:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.