2

I am having trouble with the marging of my thesis. I am using a template which worked perfectly for a previous paper some 2 years ago but now when I create a pdf the margin on pages containing a \chapter between the top of the page and chapter name is not 2,5 cm as it should be. I am absolutely confused why this does not work anymore...

Here is my preamble. As I do not really understand some stuff there I have included everything that seems to affect the margins.

\documentclass[fontsize=12pt,a4paper,oneside, 
listof=totoc,                   
bibliography=totoc,             
titlepage,                      
headsepline,                    
%abstracton,                    
DIV12,                          
BCOR=0mm,                       
]{scrreprt}

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{amsmath}
\usepackage[final]{microtype}
\usepackage{mathpazo}
\usepackage{textcomp} 
\newcommand{\cbox}[1]{\parbox[t]{2cm}{\centering #1}} % no idea what this does
\usepackage{fancyhdr}
\usepackage[a4paper, left=2.5cm, right=3cm, top=2.5cm, bottom=2.5cm, bindingoffset=6mm]{geometry}
\usepackage{setspace}           
\onehalfspacing
\renewcommand*{\chapterheadstartvskip}{\vspace*{-1.1cm}}
\renewcommand*{\chapterheadendvskip}{\vspace*{0.1cm}}
\usepackage{mathptmx}
\setlength{\footskip}{1.25cm}
\setkomafont{disposition}{\bfseries}
\addtokomafont{chapter}{\rmfamily\large}
\addtokomafont{section}{\rmfamily\normalsize}
\addtokomafont{subsection}{\rmfamily\normalsize}
\addtokomafont{subsubsection}{\rmfamily\normalsize}
\lhead{\sffamily{\leftmark}}
\chead{}                    
\rhead{\sffamily{\rightmark}}
\lfoot{}                    
\cfoot{\sffamily{\thepage}} 
\rfoot{}                    
\usepackage[parfill]{parskip}

In between this I have some other pacages and macros but they dont seem to affect margins.

What I need is a DIN A4, Oneside, 12pt and Times New Roman font. The layout is supposed to be: left 2,5cm, right 3cm, top 2,5 cm, bottom 2,5cm and bindingoffset of 6mm, making left 3,1cm. I have no need for footnotes. According to this question of mine and other research I have done, it looks like there are some nuances in regard to margins.... BCOR not used inside scrreprt

the mentioned margins above mean: for left, right and bottom it is the mentioned distance in cm from the text until the end of the paper. for top it is from the chapter, text, section, subsection etc. until the end of the page top.

I know that it worked before perfectly but I just do not know what changed...

2

There were some changes in KOMA-Script. \topskip is no longer automatically inserted before chapters. So you could use \chapterheadstartvskip{}. But I would suggest to use the new way for changing the space before and after section titles:

\RedeclareSectionCommand[beforeskip=0pt,afterskip=.1cm]{chapter}

Note that you will get a warning with version 3.17a (current version on CTAN) but you can ignore this if you only change beforeskip and afterskip. There is no warning if you can use the prerelease of the next version.

enter image description here

Code:

\documentclass[fontsize=12pt,%a4paper,oneside, % defaults of the class
listof=totoc,                   
bibliography=totoc,             
titlepage,                      
headsepline,                    
%abstracton,                    
%DIV12,                          % geometry sets the page layout
%BCOR=0mm,                       % geometry sets the page layout
parskip=full-% instead of \usepackage[parfill]{parskip}
]{scrreprt}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{amsmath}
\usepackage[final]{microtype}
\usepackage{mathpazo}
\usepackage{textcomp} 
\newcommand{\cbox}[1]{\parbox[t]{2cm}{\centering #1}} % no idea what this does

\usepackage[a4paper, left=2.5cm, right=3cm, top=2.5cm, bottom=2.5cm, bindingoffset=6mm,
  showframe% show the page layout
]{geometry}
\usepackage{setspace}           
\onehalfspacing

%\renewcommand*{\chapterheadstartvskip}{}
%\renewcommand*{\chapterheadendvskip}{\vspace*{0.1cm}}
\RedeclareSectionCommand[beforeskip=0pt,afterskip=.1cm]{chapter}

\usepackage{mathptmx}
\setlength{\footskip}{1.25cm}
\setkomafont{disposition}{\bfseries}
\addtokomafont{chapter}{\rmfamily\large}
\addtokomafont{section}{\rmfamily\normalsize}
\addtokomafont{subsection}{\rmfamily\normalsize}
\addtokomafont{subsubsection}{\rmfamily\normalsize}

\usepackage[automark,markcase=upper]{scrlayer-scrpage}
\clearpairofpagestyles
\ihead{\leftmark}
\ohead{\rightmark}
\cfoot*{\pagemark}
\addtokomafont{pagehead}{\normalfont\sffamily}
%\usepackage{fancyhdr}
%\pagestyle{fancy}
%\lhead{\sffamily{\leftmark}}
%\chead{}                    
%\rhead{\sffamily{\rightmark}}
%\lfoot{}                    
%\cfoot{\sffamily{\thepage}} 
%\rfoot{}                    

%\usepackage[parfill]{parskip}% this can be done by the option parskip=full-

\usepackage{blindtext}
\begin{document}
\chapter{First chapter}
\section{First section}
\KOMAScriptVersion{}
\Blindtext
\end{document}

Note that I have removed \usepackage[parfill]{parskip} because I use the KOMA-Script option parskip=full-. Additionally I suggest to use scrlayer-scrpage instead fancyhdr.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.