2

As I was trying to compile a document with LuaLaTex, which used to compile well before, lualatex finished on an error:

luaotfload | db : Font names database not found, generating new one.
luaotfload | db : This can take several minutes; please be patient.
luaotfload | db : Updating the font names database.
luaotfload | db : Blacklisting 8 files and directories.
luaotfload | db : Whitelisting 0 files.
luaotfload | db : Scanning TEXMF and OS fonts...
luaotfload | db : Scanned 2486 files, 890 new.
luaotfload | db : Scanning OS fonts...
luaotfload | db : Searching in static system directories...
! LuaTeX error ...texmf-dist/tex/luatex/luaotfload/luaotfload-database.lua:2383:
 stack overflow (too many arguments).
<to be read again> 
relax 
l.100 \fontencoding\encodingdefault\selectfont

? 

From this thread Compilation error with LuaLaTeX (luaotfload- database.lua), though now it shouldn't be the same problem, I ran the following commands but still got exactly the same error:

$ luaotfload-tool --cache=purge
$ luaotfload-tool -u
luaotfload | db : Font names database not found, generating new one.
luaotfload | db : This can take several minutes; please be patient.
...texmf-dist/tex/luatex/luaotfload/luaotfload-database.lua:2383: stack overflow (too many arguments)

Also, I thought maybe there's still the same old buggy version on my distro, like in the thread, so I tried to:

$ sudo tlmgr restore luaotfload 31286[sudo] password for nico: 
(running on Debian, switching to user mode!)
cannot setup TLPDB in /home/nico/texmf at /usr/bin/tlmgr line 5336.

So, what can I do?

If this may be useful:

$ uname -a
Linux ometeotl 3.16.0-29-generic #39-Ubuntu SMP Tue Dec 16 20:54:13 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

$ lualatex --version
This is LuaTeX, Version beta-0.76.0-2013121407  (TeX Live 2013/dev/Debian) (rev 4627)

$ luaotfload-tool --version    
[...]    
luaotfload-tool version "2.4-3"
revision "bd307a8fe8047d322317037c1a832720c236fb48"
database version "2.41"
Lua interpreter: stock; version "Lua 5.2"
Luatex SVN revision 4627
Luatex version 0.76.0
  • Perhaps this bug report is related: github.com/lualatex/luaotfload/issues/275 – Ulrike Fischer Jul 1 '15 at 7:50
  • Well, Ulrike, your link led me back there. I tried this mv /etc/fonts/fonts.conf /etc/fonts/tmprm-fonts.conf and the error doesn't show up. It compiles fine but a font I wanted to use has been replaced by another one, so I don't know if the problem is exactly solved. It's a workaround that creates another problem - less annoying though. – zezollo Jul 1 '15 at 8:47
  • Without and example and the log-file it is impossible to tell you something about your font problem. Beside this: your luatex and luaotfload-tool is rather old. Perhaps you should consider to install texlive 2015. – Ulrike Fischer Jul 1 '15 at 9:10
  • Yes, well I don't know how the font problem is related to the first problem in this thread. Now I managed to use the font I want, but I don't know exactly why the previous way of doing it doesn't work anymore. But I guess this is an entirely different question (moreover it involves beamer). – zezollo Jul 1 '15 at 9:15
0

So, as stated in the comments, this thread: luaotfload font names database creation crashes

led me to do this:

$ mv /etc/fonts/fonts.conf /etc/fonts/tmprm-fonts.conf

Then the compilation works to the end:

$ lualatex beamer_test.tex
.
.
.

After that, I renamed the file as it was before:

$ mv /etc/fonts/tmprm-fonts.conf /etc/fonts/fonts.conf

And any further compilation does work now. I just had to add a \fontspec{Ubuntu} in each new frame (this document uses beamer) in order to have this font used (although before, \setsansfont{Ubuntu} was enough, at the beginning of the document).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.