2

When I create a long beamer frame which is automatically splitted into slides by using allowframebreaks option, it has a little bigger vertical margin for the first slide. I would like to make it more consistent with the rest of the frame. I cannot find the reason of this behavior and a way to fix it.

\documentclass{beamer}

\begin{document}

\begin{frame}[t,allowframebreaks]
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
    A\\
\end{frame}

\end{document}

Comparison

  • if you replace the backslashes with white space (to make a new paragraph instead of a line break), does the problem go away? – Mike Renfro Jul 1 '15 at 14:45
  • Yes, it happens with paragraphs and also with things like printbibliography that was the original command used when I've noticed it. – Peter Jul 1 '15 at 14:56
  • I could be misinterpreting something, but my document with each paragraph consisting of a single letter A and enough paragraphs to force the allowframebreaks option to take effect, I don't see the vertical offset you describe. There might be a pixel or two, or maybe none at all, but certainly not the nearly 50% of the baseline height you show with the backslashes. – Mike Renfro Jul 2 '15 at 3:32
  • 1
    I've checked this once again (replaced \\ with double newlines, with \pars and with regular whitespaces) – the result is always the same, i.e. as in the screenshoot comparison above. I suppose that in my case allowframebreaks seems to redefine some dimensions when switching to second slide (I use 64-bit MiKTeX). – Peter Jul 2 '15 at 9:55
  • related tex.stackexchange.com/questions/277473/… – user36296 Jan 20 '17 at 16:09
1

This problem has been fixed in https://github.com/josephwright/beamer/commit/fd369b715b9c8738da88d1589785fe48ecff1031

The fix is included in beamer versions >= 3.54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.