2

I'm trying to cite a newspaper article using biblatex with bibstyle=authoryear. But I'm not able to make visible in the bibliography the newspaper issue date. The only workaround found so far is to put the full date in the note field. For the rest of the bibliography the style is correct.

This is the entry:

@Article{Barone2006,
  Title                    = {Una intervista con Giacomo Rizzolatti},
  Author                   = {Luca Tancredi Barone},
  Journaltitle             = {Il manifesto},
  Year                     = {2006},
  Date                     = {2006-10-31}
}

And this is the result (language is Italian):

Barone, L. T. (2006). «Una intervista con Giacomo Rizzolatti». In: Il manifesto.

No sign of the full date even if I remove the Year field or if I set Month and Day fields.

Just for completeness, here are the package options:

\usepackage[%
    bibstyle=authoryear,
    citestyle=authoryear,
    language=auto,
    backend=biber,
    firstinits=true,
    uniquename=init,
    defernumbers=true,
    isbn=false,
    eprint=false,
    urldate=comp,
    sorting=nyt,
    safeinputenc=true,
    bibencoding=utf8,
    clearlang=true,
    autolang=other]{biblatex}
  • You can use the month field for displaying the month of the issue. For example:Month = {Jul} But this does not display the day. – Wamseln Jul 6 '15 at 14:58
  • Does Modifying citation style for newspaper articles in Biblatex give you any first clues? – Johannes_B Jul 6 '15 at 15:35
  • Thanks, but I prefer to leave this as "ultima ratio". – SiliconValley Jul 6 '15 at 15:49
  • Discovered that adding mergedate=basic to biblatex options display the date, but displays also ugly (and not needed) dates for all the other entries. Back to the manual... – SiliconValley Jul 6 '15 at 15:51
  • 1
    If you have found a good solution to your problem it is in no way frowned upon if you write up an answer yourself (indeed it is very much encouraged to do so). – moewe Jul 7 '15 at 20:13
2

Solution:

1) Add mergedate=basic to the biblatex options, so I have:

\usepackage[%
    style=authoryear,
    language=auto,
    backend=biber,
    firstinits=true,
    uniquename=init,
    defernumbers=true,
    isbn=false,
    eprint=false,
    urldate=comp,
    sorting=nyt,
    safeinputenc=true,
    bibencoding=utf8,
    clearlang=true,
    maxcitenames=1,
    mergedate=basic,
    autolang=other]{biblatex}

2) Correct entries to use the number field for issue number. I had few entries where I mistakenly had put the issue number in the issue field. The result was something like (3 2004) hence my reference to "strange dates".

3) Remove month where not needed (e.g., for a book). Otherwise you have e.g. a (Mar. 1999) entry appears in bibliography.

Now the newspaper is cited correctly as:

Barone, L. T. (2006). «Una intervista con Giacomo Rizzolatti». In: Il manifesto (31 ott. 2006).

Leaving the rest of the entries unharmed. Then modified JabRef as Johannes_B suggested. It is not a global ordering by year OR date, but it is better than nothing. Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.