1

After an update on MacTeX, my code stopped working. I am not sure what gives. My preference is to use PDFLaTeX (I am using the shell-escape option) but XeLaTeX is also not working.

\documentclass{article}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}

\usepackage{pstricks}
%\usepackage{auto-pst-pdf,pstricks} tried this too as well and worked for something else.

\usepackage{pst-all}
\usepackage{pstricks-add}

\usepackage{xcolor}
\usepackage{microtype}

\begin{document}
\psset{xunit=1cm,yunit=10cm}
\begin{pspicture*}(-4.2,-0.06)(4.1,0.57) 
\psBinomialN[linecolor=red,fillstyle=solid,fillcolor=lightgray,showpoints=true,markZeros]{36}{0.5}
\psaxes[Dy=0.2,dy=0.2\psyunit]{->}(0,0)(-4,0)(4,0.5)
\end{pspicture*}
\end{document}

I have tried using \begin{postscript}...\end{postscript} and that also have failed and that was something that has worked in the past as well. Can someone tell me what I am missing in order to get PDFLateX to work? For completeness, what about XeLaTeX?

There are some other things that stopped working, but I will start here.

2

Your example is missing usepackage{pst-func}. However, this works with up-to-date TL 2015 and xelatex, pdflatex -shell-escape and loading package auto-pst-pdf and also with latex->dvips->ps2pdf

\listfiles
\documentclass{article}
\usepackage{pst-func}

\begin{document}
    \psset{yunit=10cm}
    \begin{pspicture*}(-4.2,-0.06)(4.1,0.57) 
    \psBinomialN[linecolor=red,fillstyle=solid,fillcolor=lightgray,
       showpoints,markZeros]{36}{0.5}
    \psaxes[Dy=0.2,dy=0.2\psyunit]{->}(0,0)(-4,0)(4,0.5)
    \end{pspicture*}
\end{document}

If it doesn't work for you then post the filelist (at the end of your logfile)

enter image description here

  • Thanks Herbert. It works now for this example. However, I encounter new problems with a larger file. I will try to make a MWE out of it. – RobertD Jul 6 '15 at 19:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.