I'm on Windows 7 with WinEdt 9; I never need/want to use any projects, all I want is to work on one tex file at a time, so when I click on a tex file I want only this file opened by WinEdt. I've used Options Interface Project Manager section (in Application: Projects, Forms, Sounds, ...) to edit the Project.ini file, where I've set




but this had no effect -- WinEdt keeps reopening all files from the previous session.

In case this is some system-wide Project.ini, I've also edited the Project.ini file in \Users\(me)\AppData\Roaming\WinEdt Team\WinEdt 9\ConfigEx\ but this did not help either.

I vaguely remember achieving what I wanted with a previous version of WinEdt after much blind trial-and-error, but I cannot recover in memory what did finally work.

Does anybody know what shall I do?

  • See command line switches in the manual. Commented Jul 7, 2015 at 9:53
  • @UlrikeFischer So the only way is to create a shortcut and run WinEdt from it? I mean, I don't mind to create shortcut but the place in the manual about command line switches is not really easily understandable to me... Commented Jul 7, 2015 at 10:32
  • ...besides, all these options in Project.ini are there for some purpose, right? Commented Jul 7, 2015 at 10:37
  • No it is not the only way, it is one way which I would use as I don't see why you want to disable this for all projects. Beside this: Don't edit the system wide project.ini. Use the user one, and don't forget to reload it (option interface, icon "reload script". Commented Jul 7, 2015 at 11:34
  • 1
    winedt can overwrite the system project.ini at updates. Only your user data are safe. Simply doubleclick in the option interface on "project manager", this will open your user ini, change the ini and then load it. Commented Jul 7, 2015 at 13:55

2 Answers 2


The best place where to keep these simple custom changes is the "Private Settings" section of the Option Interface.

To open it, double click on "Private Settings" under "Advanced Configuration" in the Options Interface:

enter image description here

Just after the line




and then press Shift+Ctrl+F9 to reload the file. This will suffice for your requirement.

If you want, you can also add the lines




there, but they are superfluous.

  • Many thanks for the excellent answer! Already did it, it does exactly what I wanted. Commented Jul 7, 2015 at 14:44
  • @მამუკაჯიბლაძე You're welcome. Commented Jul 7, 2015 at 14:45

I have had to ask this from [email protected] embarrassingly many times. Recording the procedure here for my own benefit as well :-)

  1. Start WinEdt as an administrator (there is a button for this in Options -> Configuration Wizard).
  2. Go to Options -> Configuration Wizard again.
  3. Select the tab "Filetype Associations".
  4. Click "Modify Filetype Associations".
  5. There is a box with a caption "Command Switches". Type in "-V ". Without the quotation marks, but observe the trailing space.
  6. Click Ok.
  • 1
    Although I prefer the solution by @karlkoeller this is also good to know - especially considered that without your information I would probably never dream of it. I mean, the command line switches are documented, but how on earth would I figure out that the way to set them is to go to Modify Filetype Associations, of all places!? Commented Feb 16, 2018 at 9:03
  • 1
    @მამუკა ჯიბლაძე That's exactly why I find this difficult. From the point of view of a limited user (like me) that is not a logical place to set a command line switch. I guess that from the programmer's point of view (or from a power user's pov) it IS a logical place, because you can (???) then set different command switches to differen filetype associations. Or something like that? Commented May 29, 2018 at 5:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .