1

I solve the problem Unknown option 'francais' by installing the missing language package:

​sudo apt-get install texlive-lang-european

Now, encounter the problem Unknown language 'french', the detailed error info is as follows:

! Package babel Error: Unknown language `french'. Either you have
(babel)                misspelled its name, it has not been installed,
(babel)                or you requested it in a previous run. Fix its name,
(babel)                install it or just rerun the file, respectively.
3

The texlive-lang-european is for a bunch of European languages, among which there's not French; do

sudo apt-get install texlive-lang-french

See https://packages.debian.org/stable/tex/texlive-lang-french and https://packages.debian.org/stable/tex/texlive-lang-european for details about the packages.

  • I don't think so. I am informed texlive-lang-french is already the newest version. while running sudo apt-get install texlive-lang-french. – SparkAndShine Jul 7 '15 at 12:50
  • @SparkandShine In my test I have no problem. What's your version of TeX Live? – egreg Jul 7 '15 at 12:55
  • TeX 3.1415926 (TeX Live 2013/Debian) . My setting is: ./preamble/preamble.tex:\usepackage[francais]{babel}. – SparkAndShine Jul 7 '15 at 13:05
  • @SparkandShine What about \usepackage[french]{babel}? If it works, there's no difference with specifying francais. If it doesn't, then there's something wrong with your installation. – egreg Jul 7 '15 at 13:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.