0

Figure is superimposed over text in pdf document created from a dvi file.

Not superimposed in ps document created from the same dvi file.

\begin{figure}
\scalebox{0.9}{\includegraphics{pbar.eps}} \caption{Illustration of nonequilibrium hyperplane probabilities for the single particle decay problem; $N_{Max}=5$.  Time is made dimensionless here through a characteristic time constant $t_0$.}
\end{figure}

Here are my latex headings:

\documentstyle[12pt, graphics]{article}
\def\baselinestretch{2.0}
\textheight 10.2in \topmargin -0.8in \textwidth 6.7in \oddsidemargin
-0.2in \evensidemargin -0.1in
\parskip 0.20in
\begin{document}

I can ps to pdf to fix this, but that eliminates my top margin somehow and is therefore not an acceptable fix.

  • 3
    Adjusting these lowlevel commands yourself is usually never a good idea. Use package geometry or typearea for page layout and package setspace for the linespread. – MaxNoe Jul 7 '15 at 16:51
  • 4
    Oh, and are you really using LaTeX 2.09? – MaxNoe Jul 7 '15 at 16:53
  • 4
    As @MaxNoe implies, the \documentstyle command is from LaTeX 2.09, and I think it was recommended to stop using that about 20 years ago. – Torbjørn T. Jul 7 '15 at 16:59
  • If changing that \documentstyle is not possible, try to explicitly specify the paper size during conversion to preserve the margins. Use dvips -t a4 -Ppdf file.dvi (change a4 to letter if wanted), then ps2pdf file.ps – AboAmmar Jul 7 '15 at 17:32
  • I use winedt 7.0 and the latest miketex. – pete Jul 7 '15 at 17:51
2

The comments contain useful information even if not responsible for the particular problem you asked about in this question. You will have fewer problems if you use the correct syntax and use something like geometry as an interface for setting up the page layout.

Here is your code modified with some comments:

\documentclass[12pt]{article}% LaTeX2e uses \documentclass
\usepackage{graphicx}% for \includegraphics
\usepackage{setspace}% for double spacing
\usepackage[textheight=10.2in, textwidth=6.7in, inner=0.8in, top=.2in]{geometry}% for page layout (check for equivalence - can't test with a fragment of code only)
\setlength\parskip{0.20in}% consider using package parskip if you want no paragraph indent either; otherwise, maybe use package parskip and then set parindent to override its setting it to 0
\begin{document}
\doublespacing% double-spacing
\begin{figure}
\includegraphics[scale=0.9]{pbar}% better not to include the extension; \includegraphics has a scale key so no need for an additional command
\caption{Illustration of nonequilibrium hyperplane probabilities for the single particle decay problem; $N_{Max}=5$.  Time is made dimensionless here through a characteristic time constant $t_0$.}
\end{figure}
\end{document}

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.