1

Please find below a snapshot of my Table Of Content page. When I click on links to pages ii, v, vi, and vii, the first page (title page) shows up. But the links for chapter pages work correctly. How can I solve this issue?

enter image description here

8
  • Please find a minimal-example here. Please download the three files in this link into a folder and run the .tex file. drive.google.com/… – Salivan Jul 9 '15 at 1:25
  • 1
    try tex.stackexchange.com/questions/44088/… or tex.stackexchange.com/questions/56521/… may be all what you need is to update your hyperref package. – touhami Jul 9 '15 at 1:34
  • touhami: As "Dedication" and other sections before "Chapters" are created automatically, and not by me, so I cannot add \phantomsection to those sections. Therefore, the solutions suggested in the two links could not help me. Thank you though! – Salivan Jul 9 '15 at 1:45
  • I don't see why not. The definition for the dedication page is on line 115 of your .sty file. The definition for the list of figures is on line 195, etc. – Mike Renfro Jul 9 '15 at 2:46
  • I see what you mean Mike, It is the part for my figures, for example: \def\listoffigures{% \newpage \addcontentsline{toc}{chapter}{LIST OF FIGURES} \@restonecolfalse\if@twocolumn\@restonecoltrue\onecolumn\fi \hbox{ } \twoinmar \centerline{\large\bf LIST OF FIGURES} \vspace{0.7in} \begin{doublespace} \@starttoc{lof}\if@restonecol\twocolumn\fi \addtocontents{lof}{\noindent\underline{\bf Figure}\hfill\rm\protect\newline} \end{doublespace} \pagestyle {empty} } How should I change this? – Salivan Jul 9 '15 at 3:11