7

I am using the revtex4-1 file apsrmp4-1.bst for my bibliography style, but am not using \documentclass[...]{revtex4-1} for the class option. That is, my document is something like

\documentclass[...]{puthesis}
\usepackage[authoryear]{natbib}
\begin{document}
...
\bibliographystyle{apsrmp4-1}
\bibliography{bib}
\end{document}

This works fine as is, but I would like to use the longbibliography option of apsrmp4-1 to display the titles of all references. The REVTeX documentation (and this question) suggests the longbibliography option should be put in \documentclass[longbibliography,...]{revtex4-1}, but this does not work for me because I'm not using the revtex4-1 class. Any suggestions for where the option can be specified?

8

The longbibliography option works by writing some commands to a .bib file that is read by bibtex. In a standard revtex4-1 document the name of this file is XXXNotes.bib where XXX.tex is the name of your tex file.

For a different documentclass you can get titles to appear by adding

@CONTROL{REVTEX41Control}
@CONTROL{apsrev41Control,author="00",editor="1",pages="1",title="0",year="0"}

to the top of your own bibliography file and adding \nocite{apsrev41Control} to your .tex file. To switch titles off, write title="" instead in the second line.

Sample output

.tex file:

\documentclass{article}

\usepackage[authoryear]{natbib}

\begin{document}
\cite{art}

\nocite{apsrev41Control}
\bibliographystyle{apsrev4-1}
\bibliography{\jobname}
\end{document}

.bib file

@CONTROL{REVTEX41Control}
@CONTROL{apsrev41Control,author="00",editor="1",pages="1",title="0",year="0"}

@Article{art,
  author =   {Author, A.},
  title =    {Title is here},
  journal =      {Jour.},
  year =     2000,
  volume =   2,
  number =   1,
  pages =    {1--23}
}

If you want to avoid modifying your own .bib file, create a new .bib file, say mycontrol.bib with the above two lines and pass it to bibtex by adding it as an argument to the \bibliography command, e.g.

 \bibliography{mycontrol,mymainbibfile}

You can get some explanation of the other options by looking in a .bbl generated by a revtex4-1 document which includes comments such as

%Control: key (0)
%Control: author (0) dotless jnrlst
%Control: editor formatted (1) identically to author
%Control: production of article title (0) allowed
%Control: page (1) range
%Control: year (0) verbatim
%Control: production of eprint (0) enabled
  • 1
    Thanks! However, bizarrely, this only works for me if I use \nocite{*} (which I'd rather not have to do as I have a rather large .bib file). Also, the XXXNotes.bib file is not being created. I tried creating this manually (and adding the @CONTROL{...} statements (which were there in a real REVTeX example I had), but it didn't seem as though LaTeX could recognize this. – Jono Jul 9 '15 at 14:22
  • 1
    Yes, I trashed all auxiliary files, and removed the .bbl file each time. It seems as though it isn't recognizing the two @CONTROL statements at the start of the bib file (unless I use \nocite{*}), since if I change other aspects (e.g., author or year), it doesn't recognize this either. In the console after running bibtex it says Control: production of article title (-1) disabled. – Jono Jul 9 '15 at 14:46
  • 2
    Made it work! Added \nocite{apsrev41Control} rather than \nocite{*}. Thanks for the help! – Jono Jul 9 '15 at 15:08
  • 1
    Indeed, I have just rechecked this and this \nocite command is necessary. I have updated the text of my answer. – Andrew Swann Jul 9 '15 at 18:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.