4

My LyX system 2.1.3 cannot find my MacTex installation. When I choose Tools -> Tex Information, it appears completely blank.

So far I've done the following:

  1. Completely removed MacTex 2015 and reinstalled it.
  2. Reinstalled LyX.
  3. Opened LyX through the terminal and reconfigured it.

I am running OS X El Capitan.

Thank you for any help you might provide!

6

Path handling has changed due to the new security framework in El Capitan. To fix it, go to the Paths item of Lyx → Preferences. Change the contents of the PATH prefix box from /usr/texbin to /Library/TeX/texbin. Then go to Tools → reconfigure and reset LyX.

2

El Capitan has made some changes related to access to the /usr folder. The /usr folder is now read only even to the admin account. So the tex applications like MacTex are not able to create a symlink /usr/texbin to texbin folder. If one (not your case though since you reinstalled, just mentioning for the sake of generality) already had an installation of MacTex/Tex in previous OSx versions then the OSx update to El Capitan will remove the /usr/texbin symlink. Now either you can (re)install latest MacTex or follow the instructions below to symlink the existing Tex installation manually (as @DrMickeyLauer) mentioned in his answer:-

cd /Library/TeX
sudo ln -s Distributions/Programs/texbin texbin
echo "/Library/TeX/texbin" >~/Desktop/TeX
sudo cp ~/Desktop/TeX /etc/paths.d/TeX

Then run the following command to make the path available for current session :-

eval $(/usr/libexec/path_helper -s)

Confirm that the path is available :-

echo $PATH

If you want to rehash the files now, run :-

sudo texhash

Now open Lyx and ensure that the PATH variable in the Lyx -> Preferences reflects the new path to texbin

Then run Tools -> Reconfigure and restart Lyx.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.