0

I wonder how to correctly install the WebOMintsGD font in Tex Live 2015 on Ubuntu 14.04. I tried the following code but without any success:

wget http://tug.org/fonts/getnonfreefonts/install-getnonfreefonts
sudo texlua install-getnonfreefonts
getnonfreefonts -a

But when I compile some files using WebOMintsGD, I get the following error: LaTeX errors: !pdfTeX error: pdflatex (file WebOMintsGD): Font WebOMintsGD at 720 not found. I think I'm not installing fonts correctly. Any help will be highly appreciated. Thanks

Edited

I upgraded Tex Live from 2013 to 2015 on Ubuntu 14.04 using the guidelines given in this nice answer. But have some problems. After upgrading when I check the version of Tex Live using tex --version command it gives the the following information:

TeX 3.1415926 (TeX Live 2013/Debian)
kpathsea version 6.1.1
Copyright 2013 D.E. Knuth.
There is NO warranty.  Redistribution of this software is
covered by the terms of both the TeX copyright and
the Lesser GNU General Public License.
For more information about these matters, see the file
named COPYING and the TeX source.
Primary author of TeX: D.E. Knuth.

Then I edited ~/.profile and added PATH=/usr/local/texlive/2015/bin/i386-linux/:$PATH at the end of the file .profile.

Then also: MANPATH=/usr/local/texlive/2015/texmf-dist/doc/man:$MANPATH and INFOPATH=/usr/local/texlive/2015/texmf-dist/doc/info:$INFOPATH.

I also used sudo getnonfreefonts-sys -a to install the packages and it say

Package 'webomints' already installed and no update available.

But even after this I'm still getting the same error.

Edited

Firstly I removed /.texlive2015 using

rm -rfv ~/.texlive2015

and installed fonts using

getnonfreefonts-sys -a

The command

getnonfreefonts -l

says

Installation directory: /home/yaseen/texmf
------------------------------------------
arial-urw      Arial (URW)                                          [installed]
classico       Classico (URW & Bob Tennent)                         [installed]
dayroman       DayRoman (Apostrophiclabs)                           [installed]
eurofont       Euro symbols (Adobe)                                 [installed]
garamond       GaramondNo8 (URW)                                    [installed]
garamondx      GaramondNo8 Expert (Michael Sharpe)                  [installed]
lettergothic   LetterGothic (URW)                                   [installed]
luximono       LuxiMono (Bigelow & Holmes)                          [installed]
vntex-nonfree  VnTeX nonfree (Han The Thanh)                        [installed]
webomints      Webomints (Galapagos Design Group)                   [installe

But ~/texmf$ ls doesn't show these font files.

  • What do you mean exactly with "without any success"? Did the installation failed? – Gonzalo Medina Jul 10 '15 at 14:50
  • When I compile some files using WebOMintsGD, I get the following error: LaTeX errors: !pdfTeX error: pdflatex (file WebOMintsGD): Font WebOMintsGD at 720 not found. – MYaseen208 Jul 10 '15 at 14:52
  • It would be helpful if you look through your file structure, and see whether or not files are where you expect them to be. Then, we will know whether the installation completely failed, or whether the problem is with to connection to Latx. – RobtA Jul 12 '15 at 16:11
  • How did you install TeX Live? If you installed from upstream, try removing ~/.texlive2015 and running sudo getnonfreefonts-sys -a. Never use getnonfreefonts unless you have no other choice. – cfr Jul 12 '15 at 16:55
  • 1
    @GonzaloMedina There are more answers on it than I realised. I didn't even remember writing any which is why I said it comes up a lot in comments ;). – cfr Jul 15 '15 at 2:09
1
+50

The problem here is most likely because the getnonfreefonts are already available in the shared texmf-local/ folder in /usr/local/texlive/texmf-local. However the corresponding Map files are not enabled and thiws LaTeX does not know where the fonts are. Thus these .map files have to be enabled.

Ulrike Fischer mentioned that since these fonts are not related to tlmgr it might be an idea to make a custom updmap.cfg for texmf-local which updmap will then pick up and use.

Here is how I made mine (you might need to be root)

  1. Go to texmf-local, on my setup this is /opt/texlive/texmf-local, you can ask TL you provide it via kpsewhich -var-value TEXMFLOCAL
  2. Make sure the web2c subfolder exists, make it if it does not exist
  3. Now run

    find . -name \*.map
    

    Which will find all the .map files under texmf-local.

  4. Copy this output into web2e/updmap.cfg and edit it so each line looks like

    Map name.map
    

    (you will need to remove a lot of ./path/path/ stuff)

  5. Now run

    texhash
    updmap-sys --syncwithtrees
    

    The first command updates the ls-R DBs, so LaTeX now knows about our extra updmap.cfg. The other command use this extra information to sync all the updmap information.

You can test that it works with

 updmap-sys --listmaps | grep webo

As webo.map is the Map file for WeboMints

For reference, here is what my /opt/texlive/texmf-loca/web2c/updmap.cfg ended as:

Map dayroman.map
Map webo.map
Map ugm.map
Map zgm.map
Map ffu.map
Map ua1.map
Map ulg.map
Map zpeu.map
Map classicovn.map
Map garamondvn.map
Map ul9.map
Map classico.map

(duplicates removed)

  • after a year I have the same problem when I upgraded Texlive. Now the output of which pdflatex is /usr/bin/pdflatex. Would appreciate if you help me to figure out the same problem again with Texlive 2016. Waiting for your help. Thanks in advance. – MYaseen208 Sep 18 '16 at 17:54
  • Exactly what did you install? If you compare the pdflatex location with the one from your original question, they are very different. – daleif Sep 18 '16 at 18:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.