1

I'm quite new to BibLaTeX and i'm trying to modify the verbose-ibid style to my requirements. The Bibliography ist perfect but the footnotes aren't doing all the things I want.

First: In one footnote I cite a inproceeding with an editor but the editor isn't shown. Instead there ist only "—" whereas in the bibliography there is the editor.

Second: The short citation in the footnote is like this: "Author, Title. Pages." But I would like to have it like this: "Author Year: Pages."

Thanks for your help and sorry for my bad english.

EDIT: Here my document:

  \documentclass[%
   paper=a4,% 
   paper=portrait, % landscape
   pagesize=auto, % driver
   fontsize=11pt,%
   version=last, %
 ]{article} 
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\usepackage[T1]{fontenc} 
\usepackage{textcomp}    
\usepackage{lmodern}   
\usepackage[bottom,hang]{footmisc}
\usepackage[babel, german=quotes]{csquotes}
\usepackage[backend=biber, style=verbose-ibid]{biblatex}    
\ExecuteBibliographyOptions{
    sorting=nyt, % Sort by name, title, year.
    bibwarn=true, %
    bibencoding=inputenc, % (auto, ascii, inputenc, <encoding>)
    isbn=false,%
    url=false,%
    doi=false,%
    eprint=false,%  
    firstinits=false,% Initialien Erzeugen
}%  
\addbibresource{Literatur2.bib}

\begin{document}

\footcite{allkemper14}
\footcite{Haberkamm89}
\footcite[S. 3]{allkemper14}

\printbibliography[heading=bibintoc]    

\end{document}

for this Bib-entry:

@book{allkemper14,
   author = {Allkemper, Alo and Eke, Norbert Otto},
   title = {Literaturwissenschaft},
   volume = {4., aktualisierte Auflage},
   address = {Paderborn},
   publisher = {Wilhelm Fink},
   year = {2014},
}

And the third footnote gives out this: Allkemper und Eke, Literaturwissenschaft, S. 3. But i would like to have this: Allkemper und Eke 2014: S. 3.

3

Following my solution to Biblatex: First citation as full reference and following citations ibid or - when interrupted - short citation we can redefine the cite:short macro of verbose-ibid.cbx

\renewbibmacro*{cite:short}{%
  \printnames{labelname}%
  \setunit*{\nameyeardelim}%
  \iffieldundef{labelyear}
    {}
    {\printtext[bibhyperlink]{%
       \printfield{labelyear}%
       \printfield{extrayear}}}}

For this we will have to add labeldate to biblatex's options (as in \usepackage[backend=biber, style=verbose-ibid, labelyear]{biblatex}).

Finally, we redefine a few delimiters in order to get a mere space between name and year and a colon before the page number.

\renewcommand*{\nameyeardelim}{\addspace}
\renewcommand*{\postnotedelim}{\addcolon\space}

MWE

\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\usepackage[T1]{fontenc}   
\usepackage{lmodern}  
\usepackage[babel, german=quotes]{csquotes}
\usepackage[backend=biber, style=verbose-ibid, labelyear]{biblatex}    
\addbibresource{biblatex-examples.bib}


\renewbibmacro*{cite:short}{%
  \printnames{labelname}%
  \setunit*{\nameyeardelim}%
  \iffieldundef{labelyear}
    {}
    {\printtext[bibhyperlink]{%
       \printfield{labelyear}%
       \printfield{extrayear}}}}

\renewcommand*{\nameyeardelim}{\addspace}
\renewcommand*{\postnotedelim}{\addcolon\space}

\begin{document}
\footcite{geer}
\footcite{worman}
\footcite[3]{geer}

\printbibliography 
\end{document}

gives

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.