4

Trying to use screenplay-pkg.sty with memoir document class. This gives the error-message:

! Undefined control sequence.
\@screenspacing ->\onehalfspacing

but using document class "book" compiles correct.

Any ideas?? MWE

\documentclass{memoir}
%\documentclass{book}
\usepackage{screenplay-pkg}
%===================================================
\begin{document}
\begin{screenplay}
\fadein
\intslug{office}

X entering the room.

\begin{dialogue}{X}
  Blah..
\end{dialogue}
\end{screenplay}

\end{document}

2 Answers 2

3

This is caused by the \EmulatePackage feature of the memoir class. It emulates the setspace package and seems to disable some stuff thereby. This feature can be switched off using \DisemulatePackage{setspace}.

The reason, why it works with book class is that screenplay-pkg loads setspace already.

\documentclass{memoir}
%\documentclass{book}
\DisemulatePackage{setspace}
\usepackage{screenplay-pkg}
%===================================================
\begin{document}
\begin{screenplay}
\fadein
\intslug{office}

X entering the room.

\begin{dialogue}{X}
  Blah..
\end{dialogue}
\end{screenplay}

\end{document}
0
1

The screenplay-pkg package (as of v1.1) now checks for memoir and uses its spacing commands, if the class is loaded, so \DisemulatePackage should no longer be used.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .