Errors—Fix is required for IEEE Xplore compatibility The report says: Which means: Bookmarks found in document

The document contains bookmarks. Document contains link annotations

The document contains hypertext links to locations in the document. Form Fields found in document

The document contains form fields. Document contains security

Some level of security has been applied to all or part of the PDF. This includes a password. Font ### is not embedded

The font listed was not embedded Font ### is not subsetted

The font listed was not subsetted (at 100%)

closed as unclear what you're asking by pluton, Svend Tveskæg, percusse, Andrew Swann, Paul Gaborit Jul 13 '15 at 7:49

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 3
    What is your question? – phx Jul 11 '15 at 11:36
  • You have to use LaTeX and typeset your paper using ieeetran document class. You are probably trying to upload your own custom PDF. Hence this question is unfortunately off-topic here – percusse Jul 13 '15 at 7:05
  • I was using Foxit Reader just to save the file as a different name, and I got the error "The document contains form fields!" in Then, when I submitted my original file (that's not saved as another name by Foxit Reader), everything was fine. – Alisa Feb 10 '16 at 17:20
  • I was using Foxit Reader to "Save file as another name" and I constantly got "The document contains form fields" error message! I just used my original PDF file without "saving as" ... in Foxit Reader. – Alisa Feb 29 '16 at 17:11
  1. You are probably using package hyperref. I think this is what is creating the bookmarks IEEE pdf express complains about. Thus, try removing the \usepackage{hyperref}, if any.

  2. Regarding the fonts: Here the culprit most likely are graphics, either in eps or pdf format. If you have a graphic with text which does not also contain the font, the font will be missing in the document as well. You have basically two choices here: a) In whatever tool you are using to create the graphics, look for an option to explicitly contain the fonts into the exported graphics. b) Export the text not as text but as curves. If there is no text, no fonts can be missing (ugly solution).

  3. For the fonts, you may alternatively try to pipe your paper through ghostscript with some settings like

gs -q -dEmbedAllFonts=true -dSubsetFonts=true -dCompressFonts=true -dOptimize=true -dPreserveCopyPage=false -dPreserveEPSInfo=false -dPreserveHalftoneInfo=false -dPreserveOPIComments=false -dPreserveOverprintSettings=false -dPreserveSeparation=false -dPreserveDeviceN=false -dMaxBitmap=2147483647 -dDownsampleMonoImages=false -dDownsampleGrayImages=false -dDownsampleColorImages=false -dDetectDuplicateImages=true -dHaveTransparency=true -dFastWebView=false -dNOPAUSE -dQUIET -dBATCH -dSAFER -sDEVICE=pdfwrite -dAutoRotatePages=/PageByPage -sOutputFile=myNewPdf.pdf myCurrentPDForPSFile.pspdf -c ".setpdfwrite <</NeverEmbed [ ]>> setdistillerparams"

where you replace myNewPdf.pdf with the file name of the pdf file you want to create (the one that should contain all fonts) and myCurrentPDForPSFile.pspdf with the file name of the document you want "repair", which can either be a postscript file (coming from dvips after latex) or an existing pdf file (from pdflatex). This command then should try its best to include all fonts (while also doing some other enhancements). This is for Linux, for Windows replace gs with gswin32c or gswin64c, depending on what version of ghostscript you have.

  1. Regarding the form fields and security: I don't know how you managed to do that with LaTeX. Are you sure you are using LaTeX and not Word or something? (Well, in that case, my points 2. and 3. may still help, but 1. obviously not).

Not the answer you're looking for? Browse other questions tagged or ask your own question.