I just installed MacTeX 2015 on OS X 10.6.8, and it is typesetting significantly slower than the 2014 distribution; for one particular file, 2014 will typeset it in 11 seconds, but 2015 takes 77 seconds (!). Has anyone else had this problem? If not, any ideas on what might cause this? Thankfully, MacTeX added a Preferences pane that makes it easy to switch back to old versions.

/Library/TeX/texbin is still in my path, the TeX file in /etc/paths.d points to the same thing, and the texbin in /usr is also from the 2015 install. I'm not sure what would need to be changed if the path is the problem.

The slowdown occurs with all the files I've tried, but here's a relatively short one that shows quite a difference: http://freitag.creighton.edu/Example.tex

This runs in about 4 sec. using 2014, but 35 sec. using 2015. Using 2015, it hangs between the lines




in the console, although that's not the case for all the files I've tried.

  • 4
    most likely your paths are not set up correctly in the 2015 install so it is having to search the filesystem for files rather than use the pre-cached kpse ls-R files. Jul 11, 2015 at 17:31
  • @DavidCarlisle Would the correct way to rectify that be sudo texhash? Jul 11, 2015 at 21:19
  • @DavidCarlisle Doesn't it usually just say it can't find things in that case?
    – cfr
    Jul 11, 2015 at 21:52
  • 1
    Does this happen every time or only the first time? Or only the first time after reenabling 2015? Because some things have to be redone e.g. caches created for a new installation. Especially if you are using XeTeX or LuaTeX or if you are using metafont fonts. Also Biber and probably some other things.
    – cfr
    Jul 11, 2015 at 21:53
  • 3
    What is the console output just before and just after the slow down? What is the smallest document you can reproduce the slowdown with? Could you post it here so we can try reproducing it?
    – cfr
    Jul 12, 2015 at 1:17

1 Answer 1


The mhchem package v4.x is very very slow! In your file (Example.tex), you may try to replace:


by the following lines (and use a faked \ce macro):


As you use mhchem v3 features, you may download and use an old version of mhchem (v3.21):


Here, you can compare durations of compilation:

mhchem v4.01    => 13.0s
mhchem v3.21    =>  1.7s
faked \ce macro =>  0.2s
  • Wow. What is going on in the package? \tracingmacros of a subset of the example gave me a log file with millions of lines ... Jul 12, 2015 at 10:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .