2

There was an earlier discussion here about line spacing when using the para option of package footmisc. I am facing a related, but slightly different problem, when using footmisc or, to be more precise, the ednotes package that builds upon it. Namely, I would like the body of my text (a critical edition) to be double spaced, but the footnotes single space. When my second footnote stream does not use the [para] option, it works fine. Here is a MWE:

\documentclass{article}
\usepackage{setspace}
\usepackage[para]{ednotes}
\usepackage{kantlipsum}

\DeclareNewFootnote{B}

\def\mylinespacing{1}

\newcommand{\NOTE}[1]{%
    \begingroup
    \linespread{\mylinespacing}
    \footnoteB{#1}
    \endgroup
    }%


\begin{document}

\begin{linenumbers} 

\doublespacing

\kant[1]
Some text here\Anote{first foot note} some more text here\NOTE{\kant[1]} and more text here\NOTE{\kant[1]}

\kant[1]
Some text here\Anote{first foot note} some more text here\NOTE{\kant[1]} and more text here\NOTE{\kant[1]}

\end{linenumbers}

\end{document}

However, I'd like both footnote streams to use the para option, so that new footnotes continue on the same line as the previous one. When I add the [para] option for the line \DeclareNewFootnote{B}, as such — \DeclareNewFootnote[para]{B} — then the single spacing which I've defined is not observed on the first page, though, strangely, it is on the second page.

I'd be grateful for any help.

  • Does it work for the first footnote series? How is that line spacing set? – cfr Jul 15 '15 at 1:10
  • 1
    There was an answer posted which may solve your problem. Unfortunately, I caused the poster to delete it. I wrote a comment saying to edit it rather than delete it but it had been deleted before I hit enter and so I could not leave the comment. Basically, corporal's suggestion was to abandon setspace and use \setlength{\baselineskip}{20.00409pt}. In general, this would be a terrible idea as it is not at all a good way to double-space. However, if you are in desperate need of a solution, it might be useful if you are very careful. Do check your document thoroughly for oddities, though. – cfr Jul 15 '15 at 2:36
  • tex.ac.uk/FAQ-linespace.html – cfr Jul 15 '15 at 2:45
  • 2
    @cfr Thanks, your comments on my (now deleted) answer were correct. It seems clear there is a bug in ednotes and although my suggestion did solve the problem for the example doc, it was not a good idea. Talazem, a bug report to the maintainer of ednotes is a good idea. – corporal Jul 15 '15 at 5:54
  • @corporal Thanks. I shouldn't have said your post didn't answer the question. I thought that when I wrote it but I started over later and found it did. I'm very sorry about that. I don't know whether it is a bug proper or an inevitable limitation of some method used to create the footnotes. If you play around with things you can get some interesting effects. E.g. you can make subsequent body text single/double-spaced, leaving the current footnote as was. Or you can change the spacing for all subsequent footnotes but not this one. And you can get weirdness for the default \Anotes, too. – cfr Jul 15 '15 at 12:27
2

An actually two-line dirty trick:

\documentclass{article}
\usepackage{setspace}
\usepackage[para]{ednotes}
\DeclareNewFootnote[para]{B}
\usepackage{kantlipsum}

\makeatletter
%% May still be useful if there are many of them:
\newenvironment{editspacing} 
               {\linenumbers\begingroup\doublespacing}
               {\endlinenumbers\restore@spacing}
%% ... \begingroup and \restore@spacing probably needed only 
%% if non-edition text follows on same page.
\makeatother

%% new dirty trick:
\let\Ofootnotesize\footnotesize
\def\footnotesize{\let\baselinestretch\empty\Ofootnotesize}
%% \Ofootnotesize usable for double-spaced footnote size
%% \small and other sizes still affected by \doublespacing

\begin{document}
 \begin{editspacing}

  \kant[1]
  Some text \Anote{here}{first foot note} some more text here\footnoteB{\kant[1]} and more text here.\footnoteB{\kant[1]}

  \kant[1]
  Some text \Anote{here}{first foot note} some more text here\footnoteB{\kant[1]} and more text here.\footnoteB{\kant[1]}
 \end{editspacing}

\end{document}

Cheers -- Uwe

  • Notes to @talazem's first posting: 1. ednotes is not based on footmisc, which works with setspace as you expect. It's based on manyfoot, which I don't maintain. I wouldn't say it's a bug, the maintainer might be asked if and how he would deal with setspace or, more generally, with non-unity \baselinestretch. For a proper, clean solution, \MFL@processpara and maybe \MFL@insert would need modification. There are two problems: (a) manyfoot does not use LaTeX's \@footnotetext that setspace redefines in order to reset \baselinestretch at a footnote entry. [full …] – user52708 Jul 20 '15 at 16:58
  • […] (b) Paragraph footnotes are reassembled when a column or page is put together during \output and my get a different line spacing than the one with which the notes were entered. manyfoot just uses the current \baselinestretch which may vary and may be different to what it was when the footnotes were entered. [too little space for remaining …] – user52708 Jul 20 '15 at 17:10
  • […] E.g., 2. the final footnotes in @talazem's example are spaced tightly because putting together the second page was triggered by \end{document}, outside the {linenumbers} environment to which the effect of \doublespacing was restricted, so \baselinestretch finally was empty again, as from article.cls. Cheers -- Uwe. (space left for a link to manyfoot) – user52708 Jul 20 '15 at 17:11
  • Excellent. Your last "trick" worked excellently. As I am using Memoir, it actually allowed me to get rid of of setspace, and just use the built in \begin{Spacing}{2} ... \end{Spacing}, alongside: \let\Ofootnotesize\footnotesize \def\footnotesize{\let\baselinestretch\empty\Ofootnotesize} Indeed, out of all the solutions, this one seems to address the way it interacts with manyfoot very nicely. Thank you. – talazem Jul 20 '15 at 22:35
1

My most recent solution has been inspired by @corporal's deleted suggestion. \doublespacing is used for \noormalsize which may have a clearly limited scope and won't affect baseline skips of any other font sizes:

\documentclass{article}
\usepackage{setspace}
\usepackage[para]{ednotes}
\DeclareNewFootnote[para]{B}
\usepackage{kantlipsum}

\newcommand*{\noormalsize}{\normalsize\doublespacing\linespread{}}
\makeatletter
\newenvironment{editspacing}
               {\linenumbers\begingroup\noormalsize}
%%%%%%%%%%%%%%%             ^ to match v
               {\endlinenumbers\restore@spacing}
\makeatother

\begin{document}
%\begin{linenumbers}
%\noormalsize
 \begin{editspacing}

  \kant[1]
  Some text \Anote{here}{first foot note} some more text here\footnoteB{\kant[1]} and more text here.\footnoteB{\kant[1]}

  \kant[1]
  Some text \Anote{here}{first foot note} some more text here\footnoteB{\kant[1]} and more text here.\footnoteB{\kant[1]}
%\end{linenumbers}
 \end{editspacing}

\end{document}

So long -- Uwe, maintainer of ednotes.

0

There are some problems with the way the packages you're using are behaving. Some bugs perhaps. If you try changing the value \def\mylinespacing{1} to \def\mylinespacing{2} it seems not to have any effect. To solve your problem try the following: replace \doublespacing by \setlength{\baselineskip}{20.00409pt}. You won't need the setspace package. To explain how I know the value 20.00409pt, I used the command \showthe\baselineskip after \doublespacing and 20.00409pt is shown in the log file, so if you are using some font size other than 10pt, you'll need a different value.

  • Please don't recommend people do this. It is A Very Bad Idea. If there is a problem, this will merely cover it up and introduce new, additional problems to boot. \doublespacing is not just a matter of setting an appropriate \baselineskip. Ideally, it should be a lot more complicated. But setspace at least smooths some of the roughest edges. In any case, this doesn't answer the question. – cfr Jul 15 '15 at 1:06
  • @cfr my suggestion does in fact solve the problem for the sample document. If you're sure what I suggest is a very bad idea, then my post should be deleted. How do I make that happen? – corporal Jul 15 '15 at 1:25
0

A near-to-clean hack, showing what could be done:

\documentclass{article}
\usepackage{setspace}
\usepackage[para]{ednotes}
\DeclareNewFootnote[para]{B}
\usepackage{kantlipsum}

\makeatletter
\newcommand*{\nobaselinestretch}{%
    \let\baselinestretch\@empty} %% or what you prefer
%% 
%% Rather than redefining \@footnotetext and \@xfloat, 
%% setspace could use \reset@font as the hook it at 
%% present cries for, as \reset@font is told to be used 
%% "in situations where typesetting is done in a new 
%% visual context (e.g. in a footnote)" in the LaTeX 
%% source documentation. In footnote macros, \fontsize
%% usually appears directly after \reset@font ... 
\def\reset@font{\nobaselinestretch \normalfont}
%% ... it is only missing in \MFL@processpara.
%% Hacking manyfoot.sty without many code lines:
\let\theMFL@joinnotes\MFL@joinnotes
\def\MFL@joinnotes{\nobaselinestretch \theMFL@joinnotes}
\makeatother

\begin{document}
 \begin{linenumbers}

  \doublespacing

  \kant[1]
  Some text \Anote{here}{first foot note} some more text here\footnoteB{\kant[1]} and more text here.\footnoteB{\kant[1]}

  \kant[1]
  Some text \Anote{here}{first foot note} some more text here\footnoteB{\kant[1]} and more text here.\footnoteB{\kant[1]}
 \end{linenumbers}
\end{document}

Cheers -- Uwe

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.