6

Quoting ConTeXt garden,

There is a font switch \em to emphasize text. This is somewhat special: it does automatic italic correction and changes the alternative depending on the current alternative.

But that is false in the current MKIV version in TL15. In fact, it seems impossible to obtain italic correction at all; \/ has no effect. Compare the ConTeXt code below to the corresponding LaTeX code. How can I get italic correction, preferably automatic?

\starttext

{\em Beef} beer.\par
{\em Beef\/} beer.\par
{\it Beef} beer.\par
{\it Beef\/} beer.

\stoptext

enter image description here

\documentclass{article}

\begin{document}

{\em Beef} beer.\par
{\em Beef\/} beer.\par
{\it Beef} beer.\par
{\it Beef\/} beer.

\end{document}

enter image description here

  • Can you elaborate further on that? – Gaussler Jul 12 '15 at 17:48
  • 1
    The quote mentions both (even if what you say is the main focus): The quote above says: "it does automatic italic correction..." I cannot see how this can be misunderstood (though "slanted correction" would be more appropriate). – Gaussler Jul 12 '15 at 17:58
  • 8
    You have to enable italic correction for your fonts, you can do this by adding \definefontfeature[default][default][itlc=yes] to your document. – Wolfgang Schuster Jul 12 '15 at 18:07
  • 1
    @Metafox It works; I'm asking myself why it's not enabled by default. – egreg Jul 12 '15 at 18:13
  • 3
    @Gaussler You can use the \setupitaliccorrection command to enable automatic italic correction. The function is described in chapter 8.2 of Hans new fonts manual (pragma-ade.com/general/manuals/fonts-mkiv.pdf). – Wolfgang Schuster Jul 12 '15 at 18:29
6

According to Hans some fonts look weird when italic correction is applied. That is why italic correction is disabled by default in ConTeXt. (In fact, most features are disabled by default in ConTeXt)

To have italic correction enabled you have define the corresponding font feature

\definefontfeature
  [italic]
  [default]
  [itlc=yes]

Now you can add the italic feature to your fonts to have fine grained control over which fonts receive italic correction. The itlc feature does not only take yes as a parameter but it can also be the factor of correction as in itlc=5. Details on this can be found in Fonts out of ConTeXt, also known as »the new font manual«.

Italic correction can be automatically applied in ConTeXt. For example it is highly desirable to have the correction in

{\em Beef} beer

This can be set up using \setupitaliccorrection[text]. There are also other options

  • global always apply correction
  • text apply correction to text
  • always correction between text and boxes
  • none forget about correction
  • For some reason, on ConTeXt MKIV v2016.05.17 (on Arch Linux), this doesn't work for me: see this M(N)WE. – digitalis_ Jan 11 '17 at 18:55
  • 1
    @digitalis_ Yes and no. This is not a fault in the mentioned procedure but there is just no italic correction to insert (you can easily verify this using an explicit italic correction). Also, this construction is typographically wrong. Punctuation after italicized words should also be set in italics. – Henri Menke Jan 11 '17 at 20:50
  • 1
    @digitalis_ Actually, some further digging revealed that it is a bug in ConTeXt. In your example you were not adding the italic feature to the font in use. You can avoid the bug by inserting manual italic correction with this workaround. – Henri Menke Jan 11 '17 at 21:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.