3

I am freaking out with this problem.

I am writting a beamer presentation in spanish, and compiling with PDFLaTeX. My input encoding has to be UTF-8. So I write:

\documentclass[12pt]{beamer}
\usepackage[utf8]{inputenc}
\usepackage{times}
\usepackage[T1]{fontenc}
\usepackage[spanish]{babel}
\begin{document}
  \begin{frame}{Test}
    Mínimo: $\min$
  \end{frame}
\end{document}

Since I need that characters <>| properly see in the output,
I need to use T1 font encoding. So I changed the font to "times".

All that seems going well, but now it emerges the problem that accented commands appear wrong. For example, the command \min has to appear as mín (with the accented "i"), since in spanish we say "mínimo".
However, the output is: "m/in" or something like that.

I need the correct output, of course: mín

Is there a way to ensure that, for all internatl definitions in babel package, accents be produced always "as if" the command \' were used?

  • Does it help if you issue \unaccentedoperators after loading babel? – Arash Esbati Jul 13 '15 at 18:53
  • @ArashEsbati: I would need the accented version, because the beamer presentation is in even spanish. Anyway, your advice was good enough. At least weird characters are not appearing now. Thank you. – pablo1977 Jul 13 '15 at 18:56
  • times is obsolete. You should use mathptmx or newtx. Note fourier also uses T1 encoding for \mathrm or \mathbf. – Bernard Jul 13 '15 at 19:01
  • 1
    Add professionalfont to your options :-) – Joseph Wright Jul 13 '15 at 19:06
  • 1
    @pablo1977 - Sorry, I got you wrong. Try a font with sans-serif math, e.g. \usepackage[math]{MyriadPro} (if you have it installed, of course). Or \usepackage{newtxtext,newtxmath} for times. – Arash Esbati Jul 13 '15 at 19:12
3

To avoid undesired inner replacements, load the professionalfonts font theme:

\documentclass[12pt]{beamer}
\usefonttheme{professionalfonts}

\usepackage[utf8]{inputenc}
\usepackage{times}
\usepackage[T1]{fontenc}
\usepackage[spanish]{babel}
\begin{document}
  \begin{frame}{Test}
    Mínimo: $\min$
  \end{frame}
\end{document}

The result:

enter image description here

By the way, as Bernard mentioned in his comment, instead of times you should use a better font package, such as mathptmx or newtx.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.