1

Related to this question, last week my portable installation of MikTex starting throwing errors. When I try to update packages, I receive the following error message...

The operation could not be completed for the following reason: The MiKTeX package management utility could not be found.

Also, when I try to run the miktex-portable.bat file, I receive the "Windows API error 2" error.

My portable distribution hasn't had these troubles the last three years. I have tried on three different computers. I even returned my laptop to Windows 8 to no avail. I just downloaded a new portable copy of MiKTeX and still the errors occur.

Might anyone have any suggestions?

Update: I don't have all the answers as to the source of the errors, but this link provided the right idea.

Download a fresh copy of portable MiKTeX. Navigate to the \miktex\bin folder and run the MiKTeX Package Manager (admin) program mpm_mfc_admin.exe. Synchronize the repository. Next run the Update MiKTeX (admin) program miktex-update_admin.exe twice.

With this method everything seems to behave.

I appreciate all the comments.

Update 2: My question is not a duplicate. I had tried the suggestion on the linked question, going as far as installing the C++ redistributable, but it didn't work. My update works.

  • Here is a similar problem with solution tex.stackexchange.com/questions/254648/… Be sure you are downloading the miktex portable from the official site. – R. Schumacher Jul 14 '15 at 2:41
  • Even official builds can have problems. About a month ago, it seems that Miktex changed the way it relies on Windows DLLs, or something like that. The gist of it is that you may need to get more recent Visual C DLL from Microsoft, and you probably need to re-install the Miktex package manager (from within the existing one is OK). If you browse the Internet, and also here, you will see that others had this problem and solved it. – RobtA Jul 14 '15 at 2:49
  • @RobtA If you provide a link to the needed information on this site, we can close as a duplicate. (I must say that I've not seen it on here, though.) – Sean Allred Jul 14 '15 at 3:07
  • See this bug report: sourceforge.net/p/miktex/bugs/2378. Also one doesn't need dll from microsoft, one only need the suitable miktex package. – Ulrike Fischer Jul 14 '15 at 7:01
  • 1
    Yes, that is the duplicate. However, the way I solved it required me to update Visual C before updating Miktex. Apparently many others do not need to update Visual C first; instead, it can be done from within Miktex as described in second link. – RobtA Jul 15 '15 at 20:44

Browse other questions tagged or ask your own question.