1

I've read all answers on "How to install "vanilla" Tex Live on Debian or Ubuntu?" and used scottkosty's script to do so. I'm getting an error at the end of installation process:

install-tl-ubuntu: install-tl finished successfully.
install-tl-ubuntu: linking...
ln: failed to create symbolic link ‘/opt/texbin/i386-linux’: File exists
install-tl-ubuntu: ERROR: could not link.

Same thing happened when I tried manual install: when getting to change the PATH variable and typing which tex the command line gave /usr/bin/tex instead of /opt/texbin/tex, which for me indicated that the symbolic link was not properly created. But, as I have pretty close to zero experience on Ubuntu command line (or command line for that matter) and just started using -falling in love with- TeX to typeset my documents though I'd ask here. What's going wrong? If so needed, what more info can I give to specify, at best, my issue?

Don't know if it matters or not, but before trying to install vanilla I had TexLive installed via apt-get texlive. Then, following a chronological order: I removed TexLive following This, tried to install vanilla using Silek's method (didn't work, as said before), removed again, finally got to the script by scott assuming I was doing something wrong, got to the same problem, where I'm still stuck.

  • Did you make sure that you had no installation installed by Ubuntu's package manager first? That is, you need to uninstall any TeX Live packages installed by your distro's package manager. The good news is that the installation was successful so you don't need to install it again. It is just a matter of creating the symbolic link. You can use the relevant part of Silke's answer for that. But make sure to remove TeX Live packages installed by apt first. – cfr Jul 16 '15 at 1:36
  • As far as removing the remainings of the previous Tex distro I did as said in "How to remove everything related to TeX Live for fresh install on Ubuntu?". Is that not it? Should I type apt-get remove texlive or something like that on the command line? – Guilherme Zanotelli Jul 16 '15 at 2:26
  • What does ls -l /opt/texbin/i386-linux /usr/bin/tex give? Did you get errors or warnings when following the removal instructions? Does a package own /usr/bin/tex? If so, which one? I mean, does it belong to a package apt knows about? (I don't know if 'own' is the right term on Ubuntu.) – cfr Jul 16 '15 at 2:43
  • @cfr I get this by running what you said ls: cannot access /usr/bin/tex: No such file or directory lrwxrwxrwx 1 root root 38 Jul 15 15:37 /opt/texbin/i386-linux -> /usr/local/texlive/2015/bin/i386-linux. I don't know enough about the system to answer the other questions, sorry... – Guilherme Zanotelli Jul 16 '15 at 2:52
  • That doesn't make much sense if which tex gives the output you said. But try sudo rm /opt/texbin/i386-linux; sudo rmdir /opt/texbin; sudo ln -s /usr/local/texlive/2015/bin/i386-linux /opt/texbin. If the second command gives you an error, STOP! In that case, report the output of ls -a /opt/texbin. – cfr Jul 16 '15 at 3:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.