2

I'm using TeXworks for writing a book in LaTex based on a Springer Template. During the first test of their sample, TeXworks asked me to install fonts\type1\urw\symbol\usyr.pfb as it is missing from the package symbol. However, whatever I try, I get following error during the installation:

starting package maintenance...
installation directory: "C:\Program Files\MiKTeX"
package repository: (http://ctan.uib.no/systems/win32/miktex/tm/packages/)
lightweight database digest: fe8645631bc046ced54f9c0c57133b55
going to download 38166 bytes
going to install 14 file(s) (1 package(s))
downloading (http://ctan.uib.no/systems/win32/miktex/tm/packages/symbol.cab...)
38166 bytes, 89.17 KB/Sec
extracting files from symbol.cab...
xdvipdfmx: Windows API error 87: The parameter is incorrect.

xdvipdfmx: Data: C:\ProgramData\MiKTeX\2.9\miktex/data/le\09b5c372fc5c4f2c55f13bbf51b8f129.fndb
Trying to make PK font usyr at 600 DPI...
Running miktex-makemf.exe...
miktex-makemf: The usyr source file could not be found.

Running ttf2pk.exe...
miktex-makepk: PK font usyr could not be created.

** WARNING ** Could not locate a virtual/physical font for TFM "psyro".
** WARNING ** >> This font is mapped to a physical font "usyr".
** WARNING ** >> Please check if kpathsea library can find this font: usyr
** ERROR ** Cannot proceed without .vf or "physical" font for PDF output...
>Output file removed.
xelatex.EXE: Broken pipe
texify: xelatex failed for some reason (see log file).
4
  • Try to install the package with the package manager. Synchronize at first the repositories (in the menu repositories). Commented Aug 12, 2011 at 16:08
  • I am not a MikTeX user but one suggestion I have come across relating to this error was that no MikTeX instances should be running when upgrading.
    – mas
    Commented Aug 12, 2011 at 17:35
  • ah, only using the package manager did it. TeXworks always upgrades itself when a new uninstalled package is used, so this second statement might not be true ... Commented Aug 12, 2011 at 18:29
  • @rubenbaetens If you solved your issue you should add that as an answer to your own question and accept it.
    – N.N.
    Commented Aug 18, 2011 at 17:10

2 Answers 2

3

As the OP did not respond, here's a community wiki answer.

The issue has been solved by using the MiKTeX Package Manager instead of automatic package maintenance, as confirmed by Ruben.

2

Solved @ http://thetruecloser.com/windows-api-error-87-the-parameter-is-incorrect/.

In short: end running MiKTeX programs, if necessary use the Task Manager to kill it, such as a running latex.exe.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .