1

I have a strange problem. In the resulting PDF of when my large (200+ pages) classicthesis.sty project is compiled, it works just nice, except that the part introductions are invisible. The text is there, it can be selected (tried both Okular and Acroread) and copied, but not viewed. It is invisible, or in the same color as the background.

I see that a similar question was asked here: Problem with includepdf invisible text in document and I have the same problems with providing a MWE. Right now I have no idea what part of my enormous document actually causes this error, and am looking more for possible sources or ways to debug this further, so I can show the relevant parts of code that causes it.

My assumption was that there were some commonalities between problems causing text in the resulting pdf to be invisible, i.e., selectable.

Update 20150925; I have now resolved the issues by updating to the newest classicthesis.sty file (2015/01/01 as of now). Then the problem disappeared. Before I commented absolutely everything out, but the problem persisted. I did not proceed to research what in the difference between the sty files made the improvement.

closed as unclear what you're asking by egreg, user13907, Heiko Oberdiek, lockstep, Jesse Aug 21 '15 at 11:01

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
  • Thanks, I'll look into it. Asking the question I assumed there would be some knowledge out there about what could cause the invisible text in resulting pdf behavior. – user1603472 Jul 16 '15 at 23:06
  • 2
    Note that creating an MWE is a debugging method. Most often, you don't have a clue what is responsible. That is precisely why you create an MWE. – cfr Jul 17 '15 at 0:14
  • 1
    Note also that the problem is probably that you are using classicthesis.sty. I say this on the basis of induction: whenever people have mysterious issues and are using this, this is almost always responsible for the mysterious issues. The best thing is not to use it. Even if you solve this problem, the package will be a source of grief to you. It will haunt your dreams and insinuate itself into your nightmares. It will breed things which go bump in the night. And that's before you even get to your viva. – cfr Jul 17 '15 at 0:17
  • I have a huge thesis so I can't switch framework now. Essentially it looks like I have to comment out sections until I find what's causing the error, as out-of-the-box it works nicely. – user1603472 Jul 17 '15 at 9:34
0

The problem lies in the classicthesis.sty file. Black is erroneously defined as cmyk(0,0,0,0) which is transparent :) Just change:

\definecolor{Black}{cmyk}{0, 0, 0, 0}

to

\definecolor{Black}{cmyk}{75, 68, 67, 90}

and you're good to go

  • There's a % in front of that definition, so this won't help. '\ctparttext' worked well until some point, remember! – PhilipPirrip Jul 22 '15 at 11:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.