3

I've installed the MacTex bundle on my machine. When I try to run $latexmk I get a 'command not found'.

I already reinstalled the latexmk bundle in TeX Live Utility. Both universal-darwin and X86_64-darwin are installed. But I still get the same error.

I would be very thankful for any solutions.

  • Welcome to TeX.SX! Are you calling latexmk from the Terminal? – egreg Jul 17 '15 at 10:46
  • What does echo $PATH give? Have you rebooted since installing MacTeX? (I'm not sure how it manages PATH these days on OS X so rebooting might not be relevant.) – cfr Oct 27 '15 at 3:59
5

I am using OX X Yosemite and I encountered exactly the same problem as you. I solved it by following steps:

  1. Launch TeX Live Utility
  2. Search for latexmk in the filter
  3. Check whether latexmk is installed in the package tab (for me it shows not installed)
  4. Install it with right click and type latexmk terminal to check

Hope it can help you.

  • Except that the question explicitly states that this is not the problem. Of course, the OP could be lying or deluded, but we have to start somewhere. – cfr Oct 27 '15 at 4:00
  • Where do I get TeX Live Utility? – tommy.carstensen Apr 28 '17 at 10:14
2

which latexmk /Library/TeX/texbin/latexmk

cd /Library/TeX/texbin/ see if it's there. Add it to your path. You can git latexmk as well and put it somewhere you like maybe /usr/local/bin the instructions are here Textmate + Latexmk

0

Alternatively, if you installed latexmk by way of tlmgr install latexmk, it may not add it to a location that is in your PATH by default. This can be resolved with tlmgr path add.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.