1

I am new with Texmaker and earlier only typed with overleaf. In my project as I tried to quick build it , Tex maker shows this error-

{! TeX capacity exceeded, sorry [parameter stack size=10000].\@fileswithoptions #1->\@ifnextchar [{\@fileswith@ptions #1}{\@fileswith@pti... \usepackage{}

While my body of document is like

\documentclass[article, 12 pt]
\usepackage{epsfig,epic,eepic,units}
\usepackage{url}
\usepackage{longtable}
\usepackage{mathrsfs}
\usepackage{multirow}
\usepackage{bigstrut}
\usepackage{amssymb}
\usepackage{centernot}
\usepackage{graphicx}
\usepackage{floatrow}
\usepackage{braket}
\begin{document}

\section{Prelimanries}
We define a Group ring, RG, where \(R\) be any ring and \(G\) be any group, to be the set of all formal linear combinations of the form
\[\alpha= \sum_{g\in G} a_gg\]
where \(a_g\in R\) and \(a_g=0\) almost everywhere.\\
\((RG,+,.) \) is a ring under + and . defined as follows-
\[\alpha+\beta = \sum_{g \in G} a_gg +\sum_{g\in G} b_gg = \sum_{g in G} (a_g + b_g)g\]



---- More text

\end{document}

What is the problem?

  • 1
    Do you really have \documentclass[article,12pt], and not \documentclass[12pt]{article}? – Torbjørn T. Jul 20 '15 at 9:02
  • ohh thanks. It worked. \documentclass[article,12pt] works on overleaf but not in texmaker. Thanks – Bhaskar Vashishth Jul 20 '15 at 9:04
  • It should make no difference if you compile that on Overleaf or on your computer, it's the same underlying system. The only difference is likely that Overleaf runs in nonstopmode, so when encountering errors LaTeX tries to do something reasonable, which in some cases can give you reasonable looking output. You should surely have gotten some error messages in Overleaf. – Torbjørn T. Jul 20 '15 at 9:06
  • Hmm.Can you also tell me if I want to use \chapter control sequence and make chapters and ten sections, what should I do in above programme as it doesnot take in\chapter – Bhaskar Vashishth Jul 20 '15 at 9:10
  • See the last part of my answer. – Torbjørn T. Jul 20 '15 at 9:14
1

The correct syntax for specifying a documentclass is

\documentclass[<options>]{<name of class>}

so \documentclass[article,12 pt] is wrong. The correct syntax is

\documentclass[12pt]{article}

If you try compiling a document like

\documentclass[article, 12 pt]
\usepackage{graphicx}
\begin{document}
Hello world.
\end{document}

on Overleaf you should see a message like this:

enter image description here

Using \chapter

As any basic LaTeX introduction will (or at least should) tell you, the article class does not define a \chapter sectioning level, as it is intended for shorter documents where having chapters is "too much". If you want to use \chapter, change to a report or book-like class. This includes for example the standard classes report and book, the KOMA-classes scrreprt and scrbook, and memoir. Hence, you want something like

\documentclass[12pt]{report}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.