1

I have got some unexpected Problem using TikZ in LaTeX. When I add TikZ via \usepackage{tikz}, the foot margin is doubled. Any ideas in how to solve this? Or where the Problem is?

Minimal Examples:
All is fine:

\documentclass[a4paper]{scrreprt}
\begin{document}
    Fooooo
\end{document}

And broken footer:

\documentclass[a4paper]{scrreprt}
\usepackage{tikz}
\begin{document}
    Baaaar
\end{document}

PS: I am using TeXlive 2014.20141024 (Packages from Debian jessie)

  • 2
    I don't see any change on my system. – percusse Jul 20 '15 at 9:24
  • 1
    Welcome to TeX.SX! I can not reproduce this behaviour. Please load the package showframe and you will see that both your examples look the same. Maybe you are missing some code in your MWE which is needed in order to show the issue. – LaRiFaRi Jul 20 '15 at 9:24
  • I checked the example on 2 different machines both with the same behaviour. With exactly this code :( Okey funny thing with showframe - same behaviour as with tikz. The thing is: without i got an footmargin about 2cm with i get round about 4cm... But ill print it later to cross check.... – user82255 Jul 20 '15 at 9:28
  • I see how you can measure the margin using package showframe, but how do you do it if the page is almost completely empty? – Johannes_B Jul 20 '15 at 9:41
  • The offset of the page numbering. I also made some tests with the lipsum package with same result. Measured using different pdf viewers and looked both files pre/and post tikz ... – user82255 Jul 20 '15 at 9:45
3

Use

\documentclass[a4paper,pagesize]{scrreprt}
\usepackage{typearea}
%\usepackage{tikz}
\begin{document}
    \KOMAScriptVersion
\end{document}

to ensure that A4 is used even if your KOMA Script version is older than 3.17


Explanation:

All KOMA-Script classes load package typearea to set the page layout.

With KOMA-Script versions older than 3.17 the typearea option pagesize needs to be set to send the page size information to the output driver. If this option was not set and no other package sends this information the default paper format of your installation is used.

Note that the standard classes also do not send this information to the output driver. You have to load a package like geometry or typerarea to do this.

Since version 3.17 typearea option pagesize=auto is set by default. To get the former behaviour you have to use pagesize=false explicitly.

  • Thank you very much, this solved my Problem KOMAScriptVersion was/is v3.12 2013/12/19 – user82255 Jul 20 '15 at 11:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.