0

I've read the similar questions with no avial. Any help would be appreciated!

Using TeXworks on Windows 7. Have

tex_file.tex:

\documentclass{article}

\begin{document}
\cite{merton80}

\bibliographystyle{plain}
\bibliography{bib_file}
\end{document}

and bib_file.bib:

@article{merton80,
author = ``Robert C. Merton'',
title = ``On Estimating the Expected Return on the Market'',
year = ``1980'',
journal = ``Journal of Financial Economics'',
volume = ``8'',
pages = ``323--361''
}

Attempts included running pdfLaTeX+MakeIndex+BibTeX selected in the Typeset command, and running in turn, pdfLaTeX on tex_file.tex, BibTeX on tex_file.aux, pdfLaTeX on tex_file.tex and again pdfLaTeX on tex_file.tex. Both resulted in the same pdf: enter image description here

When I open tex_file.bbl, it contains

\begin{thebibliography}{1}

\bibitem{merton80}


\end{thebibliography}
  • 1
    Wrong format in the bibtex data, use the " around the data entry, not ` `` ... ''`. Bibtex show give error or warning about this, but some editors never inform the user when there is bibtex warnings or errors – daleif Jul 20 '15 at 13:55
  • @Mico, sorry, it was .bib for compilation. Typo. – bcf Jul 20 '15 at 14:03
-1

Remove the `` '' and put curly brackets around the arguments

like

author = {Robert C. Merton},

if you want a part to be exactly like you entered, you may choose another set of brackets

author = {{Robert} C. Merton},

this will not get abbreviated to R. C. Merton (independent from bib-style). This is also needed, if you need special characters or commands, say

author = {Robert C. Mert{\" o}n}

|improve this answer|||||
  • It is absolutely not the case that writing author = {{Robert} C. Merton} will keep the first name from being abbreviated to "R.". Please correct your write-up immediately. – Mico Jul 20 '15 at 14:08
1

This works just fine, the format states that you should use either {...} or "..." around entries.

\begin{filecontents}{bib_fileX.bib}
@article{merton80,
author = "Robert C. Merton",
title = "On Estimating the Expected Return on the Market",
year = "1980",
journal = "Journal of Financial Economics",
volume = "8",
pages = "323--361" 
}
\end{filecontents}
\documentclass{article}

\begin{document}
\cite{merton80}

\bibliographystyle{plain}
\bibliography{bib_fileX}
\end{document}
|improve this answer|||||
  • teXworks automatically changes double quotes to two single quotes. Do you know how I can stop this? Manually typing in two single quotes didn't work, either – bcf Jul 20 '15 at 14:02
  • @bcf Use braces instead, seems simpler than hacking around at a different site title= {Walzing wombats are happy} – Johannes_B Jul 20 '15 at 14:05
  • @bcf usually you just type it twice to get the real character – daleif Jul 20 '15 at 14:08
  • @bcf - You can disable the setting in TeXworks that replaces double quotes with pairs of single quotes. – Mico Jul 20 '15 at 14:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.