2

I've the following strange edition for a document.

@Book{howell15:_ode,
  language =     {english},
  author =   {Howell, Kenneth B.},
  title =    {Ordinary Differential Equations:
              An Introduction to the Fundamentals},
  publisher =    {Hayden-McNeil Publising},
  year =     2015,
  edition =  {2014--2015},
  where =    {http://howellkb.uah.edu/DEtext}
}

With babelbib and cite packages, and babplain-fl, I get output like (transcribed from the PDF):

[404] Kenneth B. Howell, Ordinary Differential Equations: An Introduction to the Fundamentals. Hayden-McNeil Publishing, --20152014-2015 edition, 2015.

Note the strange edition formatting, it is not a mistake in the .bib file. It should come out somewhat like "2014-2015 edition".

Any suggestion on how to get a somewhat reasonable output? As the reference number shows, this is in an extensive set of entries, so any tweaking of the bibliography style to "fix" the handling of the edition tag generally (except for such situations) is out of the question. Placing {} around the string doesn't help.

I'm using texlive, as it comes with Fedora 22 (current versions of both).

An MWE follows:

\documentclass[czech, english, german, french, latin, spanish, romanian]
              {article}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{babelbib, cite}

\begin{document}
\selectlanguage{spanish}
\thispagestyle{empty}
\bibliographystyle{babplain-fl}

\nocite{*}

\bibliography{mwe}
\end{document}

The corresponding mwe.bib file follows:

  @Book{howell15:_ode,
  language =     {english},
  author =   {Howell, Kenneth B.},
  title =    {Ordinary Differential Equations:
          An Introduction to the Fundamentals},
  publisher =    {Hayden-McNeil Publising},
  year =     2015,
  edition =  {{2014--2015}},
  where =    {http://howellkb.uah.edu/DEtext}
}
  • I am unable to reproduce the problem you report, ie. the extra "2015" string in the formatted edition field. I'm loading the babel, babelbib, and cite packages, I've set "english" as the language option, and I'm using the babplain-fl bibliography style. Please post a full MWE that generates the problem behavior. Maybe you're loading some other package that interacts in a bad way with LaTeX and/or BibTeX. – Mico Jul 20 '15 at 23:10
  • @Mico, the main language is Spanish. The bibliography contains a host of entries in assorted languages. – vonbrand Jul 21 '15 at 0:46
  • The main document language in your example is Romanian - not Spanish. – cfr Jul 21 '15 at 1:02
  • 2
    The main document language is still Romanian - not Spanish. I'm not saying that should be a problem. I'm just saying that it is Romanian as far as babel is concerned. I think the problem with edition is that you are not really meant to use a value like a date range. It expects an ordinal e.g. usually editions are e.g. 'second' or 'third'. Admittedly sometimes you get e.g. 'new' or 'revised' or whatever. But why repeat date information in the edition? – cfr Jul 21 '15 at 1:22
  • 1
    If you are sure it needs to be like that, fake it. It doesn't have to go in the edition field. Or consider using Biblatex/Biber which offers a lot more flexibility and control. – cfr Jul 21 '15 at 1:42
1

Thanks for the comments. The problem (as @Mico noted) is with the czech language. The following kludge fakes the edition:

@Preamble{"\newcommand{\noopsort}[1]{}"}

@Book{howell15:_ode,
  language =     {english},
  author =   {Howell, Kenneth B.},
  title =    {Ordinary Differential Equations:
          An Introduction to the Fundamentals},
  publisher =    {Hayden-McNeil Publising},
  year =     {\noopsort{2015}2014--2015 edition, 2015},
  where =    {http://howellkb.uah.edu/DEtext}
}

The \noopsort{} is to get the right date order, if required someday.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.