2

I am using the report class for my dissertation, which requires 2 inch margin beginning at each chapter. I am using the following command:

\titlespacing*{\chapter}{0pt}{2in}{1in}

This works fine for all the chapters. However, it doesn't work within the frontmatter. My cls file is as following.

\usepackage\[top=1in,bottom=1in,left=1in,right=1in\]{geometry}
\usepackage{titlesec}
\usepackage{setspace}
\usepackage{textcase}
\usepackage{tocloft}
\usepackage\[nonumberlist,xindy,toc\]{glossaries}

\titlespacing{\chapter}{0pt}{2in}{1in}
\titlespacing*{\chapter}{0pt}{2in}{1in}
\titlespacing*{name=\chapter,numberless}{0pt}{2in}{1in}

\newcommand{\makefrontmatter}{
  \thispagestyle{empty}
  \vspace*{50\p@}
  \begin{center}
    \begin{doublespace}
    \renewcommand{\and}{\NoCaseChange{\\}}
    \MakeTextUppercase{\@title} \linebreak \linebreak
    by \linebreak
    \MakeTextUppercase{\@author}
    \begin{singlespace}
      \MakeTextUppercase{\@adviser, Committee Chair \and \@committee}
    \end{singlespace}

    \hfill \linebreak
    \ifthesis
      A THESIS
    \else
      A DISSERTATION
    \fi
    \hfill \linebreak
    \begin{singlespace}
      Submitted in partial fulfillment of the requirements \\
      for the degree of \@degree \\
      in the Department of \@department \\
      in the \@school\,of \\
      \@university
    \end{singlespace}
    \hfill \linebreak
    \hfill \linebreak
    \MakeTextUppercase{\@place}
    \hfill \linebreak
    \hfill \linebreak
    \@gradyear
  \end{doublespace}
  \end{center}
  \pagebreak

    \begin{frontmatter}

    \chapter*{ABSTRACT}
    \addcontentsline{toc}{chapter}{ABSTRACT}

    \@abstract

    \chapter*{DEDICATION}
    \addcontentsline{toc}{chapter}{DEDICATION} 
    \@dedication

    %% Print everything in the glossary.
    \glsaddall
    \printglossary
    \glsresetall

    \chapter*{ACKNOWLEDGMENTS}
    \addcontentsline{toc}{chapter}{ACKNOWLEDGMENTS}

    \@acknowledgments

    \begin{singlespace}
    \tableofcontents

    \listoftables 
    \addcontentsline{toc}{chapter}{LIST OF TABLES} 

    \listoffigures
    \addcontentsline{toc}{chapter}{LIST OF FIGURES} 
    \end{singlespace}

    \end{frontmatter}

}

It does not work within the frontmatter But it works within the mainmatter

9
  • Welcome to TeX SX! I suppose you're loading titlesec. Adding to your preamble: \titlespacing*{name=\chapter,numberless}{0pt}{2in}{1in} should work.
    – Bernard
    Jul 22, 2015 at 0:58
  • Yes, I am using titlesec. However, it does not work. May be it's related to: tex.stackexchange.com/questions/170227/…
    – amiangshu
    Jul 22, 2015 at 1:12
  • Welcome! Maybe if you could post a complete example, people could test their suggestions to find out if they work or not? Why make people guess?
    – cfr
    Jul 22, 2015 at 1:51
  • 'Doesn't work' how? The question you linked looks something like a duplicate - did you try the suggestions there?
    – cfr
    Jul 22, 2015 at 1:53
  • 1
    First of all, load tocloft as the following \usepackage[titles]{tocloft}. Jul 22, 2015 at 4:51

1 Answer 1

1

I hope this works:

\documentclass[12pt]{report}
\usepackage[utf8]{inputenc}
\usepackage{blindtext} % enters dummy text in document (removable)
%\usepackage[titles]{tocloft} % use tocloft in this way
% other wise it interferes with titles settings

\title{
  {Learning Report Class}\\
  {\large Institute of Self Learning }\\
}
\author{J Kumar}
\date{\today}

\usepackage{titlesec}
\titleformat{\chapter}[display]
{\vspace{1in}} % adding 1in space which makes the total space 2in
{\Large\bfseries\chaptertitlename \thechapter}
{25pt}
{\Huge\bfseries}

\begin{document}
\maketitle

\chapter*{Abstract}
\blindtext

\chapter*{Dedication}
To my ...

\chapter*{Declaration}
\blindtext

\chapter*{Acknowledgements}
\blindtext

\tableofcontents
\clearpage

\chapter{Introduction}
\blindtext

\chapter{Chapter two}
\blindtext

\appendix
\chapter{Bibliography}

\chapter{Index} 
\end{document}

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .