3

I'm using this document class type https://github.com/praseodym/tudelft-report-latex/blob/master/tudelft-report.cls and I get the following error when I run it throgh XeLatex:

! Undefined control sequence.
<recently read> \str_case:nnn 

l.72     ]{BookmanOldStyle}

I read and tried what the following post suggests (Latest MiKTeX-Update broke XeLaTeX with fontspec), but I still have no solution. The font files are in the right path and installed.

It was working perfectly last week, but reinstalled MikTex and started having this issue.

Any idea about what is happening?

The code I'm running is

\ifxetex
    %% If the document is compiled with XeLaTeX, we load the TU Delft house
    %% style fonts: Bookman Old Style (serif) for titles and Tahoma (sans-serif)
    %% for text. Even if the nativefonts option was specified, we need these
    %% fonts for the cover.
\newfontfamily\tudrmfamily[
    Path = fonts/,
    Extension = .ttf,
    BoldFont = *-Bold,
    ItalicFont = *-Italic,
    BoldItalicFont = *-BoldItalic
]{BookmanOldStyle}
4

This is a known problem. As Joseph Wright wrote on the miktex mailing list:

Will Robertson knows about this and it will be fixed soon. For the present

 \usepackage{expl3}
 \ExplSyntaxOn
 \cs_new_eq:NN \str_case:nnn \str_case:nnF
 \cs_new_eq:NN \str_case_x:nnn \str_case_x:nnF
 \cs_new_eq:NN \int_case:nnn \int_case:nnF
 \ExplSyntaxOff
 \usepackage{fontspec}

Hopefully this will only be needed for a few days.

  • Okey perfect, I missed that...hope is fixed soon! – Yu Semanuel Jul 23 '15 at 12:29
  • @YuSemanuel Fix went to CTAN yesterday. Give them a chance to get back from the TUG meeting and install it :-) – Joseph Wright Jul 23 '15 at 12:46
  • 1
    Now the fontspec error is fixed but i get this one: ("C:\Program Files (x86)\MiKTeX 2.9\tex\latex\unicode-math\unicode-math-table.t ex"))) ! Undefined control sequence. \um_set_mathsymbol:nNNn #1#2#3#4->\tl_case:Nnn #3{\mathop {\um_set_big_opera... l.137 ]{CambriaMath} ? – Yu Semanuel Jul 27 '15 at 13:16
  • 1
    Add \cs_set_eq:NN\tl_case:Nnn\tl_case:NnF until unicode-math is updated. – Ulrike Fischer Jul 27 '15 at 13:28
  • Thanks Ulrike, where do I add that? – Yu Semanuel Jul 27 '15 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.