1

I am working with

\documentclass[12pt,twoside,openright]{amsbook}

and I wish:

  1. titles of Chapters centered in the page

  2. titles of Sections left aligned (for instance: 3. Third Section)

  3. In the contents, the full titles of the Sections and, since such titles are sometimes long, the running heads, when equal to the Sections, should be in a short form (therefore different from what appears in the contents).

Looking at the answers of this website, if I solve one question, for instance using titlesec, I see that something else goes wrong. Apparently all those conditions cannot be got at the same time!

For instance, if the command of the section is

\section[Short form]{Full title of Section}

then 1. and 3. are OK, but 2. is not OK. If I put in the main file

\usepackage{titlesec}
\newcommand*{\justifyheading}{\raggedright}
\titleformat{\chapter}[display]
  {\normalfont\bfseries\justifyheading}{\chaptertitlename\ \thechapter}
  {20pt}{\large}
\titleformat{\section}
  {\normalfont\bfseries\justifyheading}{\thesection}{1em}{}
\titleformat{\subsection}
  {\normalfont\bfseries\justifyheading}{\thesubsection}{1em}{}

and then, in the file of the chapters,

\section[Short form]{Full title of Section}

then running heads are correctly in the short form, the Sections are in their full title in the text and they are left aligned as I wish, but in the contents I read the short form of the Sections (moreover, the first letter of the short form overlaps with the number of the Section).

  • 3
    titlesec and amsbook aren't really compatible. (titlesec didn't exist when amsbook was written, and amsbook does not do things in the same way as book because it implements a different set of specs). the best way to modify the appearance is to patch the amsbook commands. i'm not where i can do that just now, but there are people who read this forum who know how to do that and can probably help. – barbara beeton Jul 24 '15 at 5:04
1

Here is a solution. ams book define section:

\def\section{\@startsection{section}{1}%
  \z@{.7\linespacing\@plus\linespacing}{.5\linespacing}%
  {\normalfont\bfseries\centering}}

so the solution is to delete \centering

\documentclass[12pt]{amsbook} %twoside,openright are defaut option of (ams)book
\makeatletter
\renewcommand\section{\@startsection{section}{1}%
  \z@{.7\linespacing\@plus\linespacing}{.5\linespacing}%
  {\normalfont\bfseries}}
\makeatother

\begin{document}
\tableofcontents
\chapter{First}
\section{Foo}
some text just dummy text
\section[Bar, long section's title]{Bar, very very very very very very very very very very very long section's title}
some text just dummy text
\newpage
some text just dummy text
some text just dummy text
\newpage
some text just dummy text
some text just dummy text
\newpage
some text just dummy text
\chapter{First}
\section{Foo}
some text just dummy text
\section{Foo}
some text just dummy text
\end{document}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.