1

Each time I tab, the entire paragraph is indented right, in the Tex editor (TeXstudio), instead of just the start of the paragraph.

How do I set the options of TeXstudio to not indent the whole paragraph in the editor when I tab the beginning of it, only show an ordinary indent? Same thing with spaces before the first word of the paragraph. Moves the whole paragraph right...

How to disable/enable this functionality? I can't find the option...

[Yes, it's useful for papers, and I use automatic indentation of TeXstudio and appreciate this functionality. Merely not when I write mostly text based material.]

  • Maybe you're confussing the usage of a text editor with another tool more accurate for notes. – Aradnix Jul 24 '15 at 20:35
  • Well, I need to be able to quickly type in mathematical formulas or commuting diagrams in tikz, and output something, as becomes necessary, so I do the notes straight in a TeX editor. Besides, there must be an option to enable / disable the indent behavior? – Guido Jorg Jul 25 '15 at 5:39
2

In fact, what is happening there is that TeXstudio is indenting the line (not the whole paragraph).

Probably what you are calling paragraph is a single line. So when TXS wraps the line it shows an arrow on the left panel (near the line number) and then if you indent that line the whole block is also indented.

If you want to indent only the first line of the paragraph you have to break the line (just hit ENTER).

See the image:

enter image description here

After compilation, the output contains a single paragraph, since there is no \par or blank line to create a new one.

But the text code is contained only in 3 lines: 14, 15 and 16.

Lines 14 and 16 contain indentation (in my case, length 2; there are 2 dots; you can configure this).

Finally, note the curved arrows to indicate that the line was wrapped.

  • Yes, of course, but there must a way to keep wrapping independent of indents or spaces to the beginning of the line, wrap within the editor field only. Most editors I've used keep this separate or separable in options if on by default. Maybe some configs can be edited? – Guido Jorg Jul 25 '15 at 7:49
  • @GuidoJorg, sorry. It is not clear what kind of situation you are working. Please, try to edit the post and insert some pictures showing the desired/undesired indentation with some piece of code. – Sigur Jul 25 '15 at 9:12
  • It's exactly as you've shown. Merely I'm trying to be able to set an option to be able 'tab' the first part of the line, shifting it right in the editor view, but let the part of the line that wraps continue to wrap to the left editor margins, like in your line 15, as opposed to line 16. – Guido Jorg Jul 25 '15 at 11:38
  • @GuidoJorg, I see. I guess that this is not possible since there is only one line. TXS is only wrapping it. Are you sure that pressing ENTER is not an option to you? Usually we format code using a lot of lines, not a single one and wrapped automatically by the editor. – Sigur Jul 25 '15 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.