The journal International Journal of Solids and Structures uses always capitalised and abbreviated form of references, i.e. Fig. 1, Eq. 1, even at the beginning of a sentence.

I use the package cleveref to adjust this globally. However, I have not figured it out how to abbreviate a reference at the beginning of a sentence using \Cref{}. I like to stick to \Cref{} to be able to change this style in case another journal uses a different style.


  c^2 = a^2 + b^2

\Cref{eqn} shows an interesting result.

Did I overlook an option in the documentation?

Current cleveref version as of 27.07.2015: 0.19.1, released May 2014, http://www.dr-qubit.org/cleveref.html

Update: no change in version 0.21 (June 2017)

  • 3
    The manual states that it's still not regarded to use the abbreviated form at the beginning of a sentence. Perhaps you have to use \Crefname{equation}{Eq.}{Eqs.} explicitly
    – user31729
    Commented Jul 24, 2015 at 14:11
  • Regarding your edit of the question: You can always contact the package author and ask for adding a feature.
    – user31729
    Commented Jul 27, 2015 at 17:17
  • As you mentioned, --- "I think adding this as an option (e.g. abbrevall) to cleveref would be better and also easy to add. The functionality is already present for \cref ... "---; I couldn't find abbrevall as an option in cleveref package and also could not find similar thing in documentation. Did you find a clear way to use all abbreviated labels?
    – novice
    Commented Jul 18, 2016 at 10:29
  • 1
    I had redefined the capital version explicitly and did not contact the author to add an option abbrevall to the package. As you can see on the website dr-qubit.org/LaTeX_Cleveref_package.html there is no new release since May 2014. If you miss this as a built-in feature, you can contact the author: see dr-qubit.org/LaTeX_Cleveref_package.html. Apparently, this feature is worthwhile adding since there are several users who would like to have this.
    – Hotschke
    Commented Jul 18, 2016 at 11:59
  • 5
    Sorry, not going to add this as a package option. In proper written English, abbreviations should not appear at the beginning of a sentence. (Probably other languages too, but that's beyond my expertise.) Throughout (La)TeX, defaults are chosen to encourage proper writing style (cf. default page margins, which get even more complaints but have not been changed). If you want to deliberately introduce poor style into your writing, cleveref gives you more than enough rope to hang yourself by setting the formats manually using \Crefname et al. (which can be done globally in a cleveref.cfg file). Commented Aug 10, 2016 at 18:29

1 Answer 1


From the (deleted) answer and comment by @Christian Hupfer and my own search, there are three possibilities:

  1. \renewcommand{\Cref}[1]{\cref{#1}}
    This does not work together with the poorman option
  2. Replace Cref by cref, e.g. with
    $ sed 's/\\Cref{/\\cref{/g' manuscript.tex > manuscript-new.tex
  3. Defining the capital labels for figure, equation, tabular, etc. explicitly (my pick):


Note, the package author of cleveref is not going to add this as a package option (e.g. abbrevall) since this is considered poor writing style (see comment by Toby Cubitt).

  • This is a bit unfortunate: IEEE requires so (page 19).
    – xuhdev
    Commented Jun 4, 2019 at 6:57
  • 1
    You could also contact Toby Cubitt the author of cleveref. Maybe he reconsiders it when many major publisher ignore the rule of no abbreviation at the beginning of the sentence.
    – Hotschke
    Commented Jun 4, 2019 at 7:00
  • Your solution works well for me. What about "Section" "Sections"? What is an appropriate abbreviation "Sect." "Sects."? So the command would be \Crefname{section}{Sect.}{Sects.} ?
    – desmond13
    Commented Sep 10, 2019 at 20:50
  • I also needed \Crefname{table}{Tab.}{Tabs.}.
    – Albert
    Commented Oct 21, 2019 at 14:05
  • Do you need ~ and . to say that . is not a period? For example, \Crefname{section}{Sect.~}{Sects.~}.
    – khatchad
    Commented Feb 21, 2022 at 16:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .