0

I was working on a beamer presentation. I want the page numbering to start from the second page (the first page is title).

But, when I used the known tweaks, the page numbering still starts from the title page, though it is hidden there. A minimal working example is given here.

\documentclass[xcolor={dvipsnames,table},11pt]{beamer}
\setbeamertemplate{footline}{\vspace*{1mm}\hfill\insertpagenumber/\inserttotalframenumber\hfill\vspace*{1mm}}
\title{Test}
\begin{document}
{\setbeamertemplate{footline}{}
\begin{frame}
\titlepage
\end{frame}}
\begin{frame}
This is the first page of mine, but it shows 2/2.
\end{frame}
\end{document}

This what I want for the given example: The second page should show 1/1 in its foot line.

Thanks in advance and waiting for a reply.

1

Here you must replace \insertpagenumber with \insertframenumber.

To turn off the frame number for the first frame you can add noframenumbering as option in the start of frame environment

\documentclass[xcolor={dvipsnames,table},11pt]{beamer}

\setbeamertemplate{footline}{\vspace*{1mm}\hfill
\insertframenumber/\inserttotalframenumber\hfill\vspace*{1mm}}
\title{Test}

\begin{document}
{\setbeamertemplate{footline}{}
\begin{frame}[noframenumbering]
\titlepage
\end{frame}}

\begin{frame}
This is the first frame of mine, it shows 1/1.
\end{frame}

\end{document}

Note that you need a second run of TEX for the account of totalframenumber.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.