0

I observe a very strange behaviour with PDFlatex.

I have recently used the beamer to create a presentation. The last compilation (with PDFlatex) was done on the 9th of April 2015. Today (July 2015), I wanted to reuse the same presentation but when I have tried to compile it, that does not work.

The problem comes from the fact that the images that I have in .eps are not converted any more to .pdf (like it was done automatically before). I am using Ubuntu and kile as Tex software. In kile I have restored the default options for compilation but without success. I am aware that I can add options like --shell-escape, maybe it works I did not try. However since it was working before without any options, I would like to understand why I have a problem now. I also want to add that my images are located in the same folder than my .tex file.

Maybe it comes from the updates of ubuntu??? Does anyone already get the same problem?

closed as unclear what you're asking by egreg, user13907, Zarko, Werner, Jesse Dec 26 '15 at 1:06

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

1

Maybe the following list is helpful to pin down the problem.

Prerequisites for a conversion of an EPS file in pdflatex:

  • The EPS file must exist and must be found by the graphics package.
  • Working ghostscript installation, especially the ghostscript must be able to convert the EPS file to PDF successfully.
  • The programs epstopdf/repstopdf, which are wrappers for calling ghostscript and which are with taking care of the bounding box.
  • graphics.cfg, which loads package epstopdf-base (when shell escape is turned on). It's the case for TeX Live and MiKTeX nowadays.
  • Restricted shell escape must be turned on (or unrestricted shell escape). It can be enabled by command line options. In TeX Live it can be configured in the configuration file texmf.cnf:

    % Enable system commands via \write18{...}.  When enabled fully (set to
    % t), obviously insecure.  When enabled partially (set to p), only the
    % commands listed in shell_escape_commands are allowed.  Although this
    % is not fully secure either, it is much better, and so useful that we
    % enable it for everything but bare tex.
    shell_escape = p
    

    Restricted shell escape is usually the default.

  • When restricted shell escape is used, then repstopdf needs to be in the list of programs, which are allowed to run. Example from texmf.cnf:

    % The programs listed here are as safe as any we know: they either do
    % not write any output files, respect openout_any, or have hard-coded
    % restrictions similar or higher to openout_any=p.  They also have no
    % features to invoke arbitrary other programs, and no known exploitable
    % bugs.  All to the best of our knowledge.  They also have practical use
    % for being called from TeX.
    %
    shell_escape_commands = \
    bibtex,bibtex8,\
    extractbb,\
    kpsewhich,\
    makeindex,\
    mpost,\
    repstopdf,\
    
0

It seems that now I have to add \usepackage{epstopdf} to induce a conversion from eps to pdf.

Moreover I have to compile using the --shell-escape option as explained in this post TeXLive 2011: pdfLaTeX does not convert eps to pdf for eps files in subdirectories.

Someone knows why I need to add these packages now?? It was working without them before (3 months ago).

  • Maybe you have changed the file graphics.cfg. Package epstopdf-base is usually loaded from there, if the (restricted) shell escape feature is enabled. – Heiko Oberdiek Aug 27 '15 at 16:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.