2

I'm a newby in LaTeX, sorry if it has already been answered but I couldn't find any that works for me. I want to number six different compounds on the same scheme, numbering just besides each substituent of an R-group. So, I have an eps file with TMP1, TMP2, ... up to TMP6 as markers, and using chemstyle package the markers are not replaced by numbers on the scheme figure, but I can mention the compounds on the text (even in a different order than in the schemes) using \compound{compound_label}.

I use TexShop on a Mac with OSX 10.10. The compilation is done with LaTeX and --shell-escape is activated.

\documentclass[a4paper]{book}

\usepackage[spanish, es-tabla]{babel}
\usepackage[latin1]{inputenc}

\usepackage{pstool}
%\usepackage[runs=2, crop=off]{auto-pst-pdf}
\usepackage{mhchem}
\usepackage{siunitx}
\usepackage{graphicx} 

\usepackage{amstext}
\usepackage{caption}
\usepackage{kvoptions}
\usepackage{xspace}
\usepackage{varioref}
\usepackage{floatrow}

\usepackage{bpchem}
\usepackage{chemstyle}

\begin{document}

\begin{scheme}[ht]
\centering
\schemeref[TMP1]{compound1}
\schemeref[TMP2]{compound1_ac}
\schemeref[TMP3]{2428DDHcompound2}
\schemeref[TMP4]{2428DDHcompound2_ac}
\schemeref[TMP5]{2324DDHcompound2}
\schemeref[TMP6]{2324DDHcompound2_ac}

\includegraphics[width=.8\textwidth]{aplysteroles2}
\caption{Some sterols and their acetates}
\end{scheme}

We have isolated compound1 (\compound{compound1}, 63,96$\%$), 24(28)-didehidrocompound1 (\compound{2428DDHcompound2}, 17,39$\%$) and 23(24)-didehidrocompound1 (\compound{2324DDHcompound2}, 19,57 $\%$), and their acetates (\compound{compound1_ac}, \compound{2428DDHcompound2_ac} and \compound{2324DDHcompound2_ac}).

\end{document}

Please find eps file here. eps file with scheme was done with MarvinSketch. I also tried with different TMP font formats but neither worked.

The pdf file is created, but without numbering the schemes. I also have tried with chemnum and got similar results.

I hope somebody could help me to find what I'm doing wrong.

1

The problem is with your .eps file. Packages which do auto-replacement, including chemstyle and chemnum, use the PSfrag system. This relies on a text-based search-and-replace being possible with the graphic. However, a quick search through your .eps shows no text TMP. This is probably down to how your editor (MarvinSketch) works, and so can only really be avoided by using an alternative editor.

  • I think MarvinSketch has converted all of the text as paths: I can't find any of of the text at all in the file. – Joseph Wright Jul 30 '15 at 16:54
  • Thanks a lot for your quick reply, Mr. Joseph Wright! I've just tried to export from MarvinSketch to 'svg' and then searched 'TMP' text on the 'svg' file, and I've found it! Now I think I have two options: 1) convert '.svg' to '.eps' with Inkscape o something like it (and cross fingers to not lose 'TMP' text) 2) try to import directly '.svg' file – Pere Ferriol Jul 30 '15 at 21:39
  • I've tried first option: export to 'svg' with MarvinSketch and then convert '.svg' to '.eps' with Inkscape, and it didn't work. But the new '.eps' file has text TMP, I can find it as a text with Preview or any similar program. This is the new eps file dl.dropboxusercontent.com/u/53475371/aplysteroles_ok.eps I think option 2) is not good to do what I want. Probably there is a third and better option: to avoid MarvinSketch and use an alternative editor... – Pere Ferriol Jul 30 '15 at 22:34
  • solved! using ChemDraw as chemical editor and '\usepackage[runs=2, crop=off]{auto-pst-pdf}' instead of 'pstool' it worked! but now show this error: floatrow.sty:485: No room for a new \count . \ch@ck ...\else \errmessage {No room for a new #3} \fi l.485 ...finable\flrow@foot{\newinsert\flrow@foot} – Pere Ferriol Jul 31 '15 at 9:07
  • The floatrow problem is entirely different. The easiest fix is to update your TeX system: the latest LaTeX kernel deals with it cleanly. Assuming that is not an option, add \RequirePackage{etex} to the start of your file (before \documentclass). – Joseph Wright Jul 31 '15 at 9:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.