tex --version returns 2013.

How can I switch to 2015?

I'm using Linux Ubuntu.

In /usr/local/texlive I see 2 directories: "2015" and "texmf-local".

Here's my output of tex --version:

TeX 3.1415926 (TeX Live 2013/Debian)

kpathsea version 6.1.1

I used https://www.tug.org/texlive/ to install.

After running the install script for a long time, it terminated without error. But I'm not sure if I'm using the new version or not.

  • 1
    We are going to need more details! What operating system do you use, exactly what did you do to install TeX, what exactly does the version string say (copy-paste)? – Joseph Wright Jul 31 '15 at 7:20
  • Check your PATH. – MaxNoe Jul 31 '15 at 7:21
  • 1
    See tex.stackexchange.com/a/95373/59023 for how to install vanilla texlive on ubuntu. – muk.li Jul 31 '15 at 8:09
  • 1
    OK, the problem is solved after I manually replace all the sym links of /usr/local/texlive/2015/arch/* --> /usr/bin. Now the version is 2015. – Yan King Yin Jul 31 '15 at 11:33
  • 1
    Please, make an answer and accept it yourself, otherwise this question will be in the queue of unanswered questions for ever. – Keks Dose Jul 31 '15 at 12:05

When different versions of TeXlive are installed on a system, one of them should be used as default and this is depending on your $PATH.

Two solutions:

  • you can remove one of the version (in your case the 2013 one)
  • modify the symbolic link used to point on the 2015 version as you have done by /usr/local/texlive/2015/arch/* pointing to /usr/bin
| improve this answer | |

Another option is to keep a softlink under /usr/local/texlive that points to the current version. You can always have more than one version and make one version current. current -> /usr/local/texlive/2015

In your .profile/.bashrc make sure to use the current path

| improve this answer | |

The problem is solved after I manually replace all the sym links of /usr/local/texlive/2015/arch/* --> /usr/bin. Now the version is 2015.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.