2

I'm having a problem with eulervm integral sign. I get the usual slanted instead of the expected upright integral sign. I'm using MikTeX 2.9 in combination with Lyx 2.1.3. This is the code exported by LyX. The result is the same in TeXstudio.

 %% LyX 2.1.3 created this file.  For more info, see http://www.lyx.org/.
%% Do not edit unless you really know what you are doing.
\documentclass[12pt]{book}
\usepackage{amsmath}
\usepackage{fontspec}
\setmainfont[Mapping=tex-text]{Footlight MT Light}
\usepackage[b4paper]{geometry}
\geometry{verbose,tmargin=3cm,bmargin=3cm,lmargin=3cm,rmargin=5cm}
\usepackage{fancyhdr}
\pagestyle{fancy}
\setlength{\parskip}{\bigskipamount}
\setlength{\parindent}{0pt}
\usepackage{color}
\usepackage{float}
\usepackage{booktabs}
\usepackage{units}
\usepackage{graphicx}
\usepackage{esint}
\usepackage[unicode=true,pdfusetitle,
 bookmarks=false,
 breaklinks=false,pdfborder={0 0 1},backref=false,colorlinks=true]
 {hyperref}
\hypersetup{
 linkcolor=RoyalBlue}

\makeatletter

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% LyX specific LaTeX commands.
%% Because html converters don't know tabularnewline
\providecommand{\tabularnewline}{\\}

%%%%%%%%%%%%%%%%%%%%%%%%%%%%%% User specified LaTeX commands.
%Footlight MT LIght, Heuristica
%\usepackage[garamond]{mathdesign}
\usepackage{eulervm}
\usepackage[usenames,dvipsnames]{xcolor}

%\newfontfamily\cyrillicfont{Minion Cyr Regular}
%\newfontfamily\cyrillicfont{Times New Roman}
\newfontfamily\cyrillicfont[Ligatures = TeX]{EB Garamond}





%\renewcommand*{\partpagestyle}{empty}


\fancyhead[RE,LO]{\leftmark}
\fancyhead[LE,RO]{\thepage}
\fancyfoot[C]{}

%Options: Sonny, Lenny, Glenn, Conny, Rejne, Bjarne, Bjornstrup
%\usepackage[Conny]{fncychap}

\usepackage{titlesec}
\renewcommand{\thechapter}{\Roman{chapter}}
\titleformat{\chapter}[display]
{\bfseries\Large}
{\filright\MakeUppercase{\chaptertitlename} \Huge\thechapter}
{4ex}
{\titlerule
\vspace{2ex}%
\filleft}
[\vspace{2ex}%
\titlerule]


%\DeclareMathSizes{10}{10.5}{7}{7}

\usepackage[labelfont={color=RoyalBlue,bf}]{caption}

\makeatother

\usepackage{xunicode}
\usepackage{polyglossia}
\setdefaultlanguage{serbian}


\begin{document}

\[
P\left(x_{1},x_{2}\right)=\intop_{x_{1}}^{x_{2}}p(x)dx
\]


\end{document}
7
  • Vielen Dank. :) Jul 31 '15 at 23:53
  • 2
    Remove \usepackage{esint}
    – egreg
    Aug 1 '15 at 6:20
  • 1
    Thank you, that worked! :) For those using LyX: Documents>Settings>Math Options There's a list of packages. Find esint and select "do not load". Aug 1 '15 at 14:43
  • 1
    @DraganPrekrat note that if you meant for your comment to be sent to egreg, you should have used the @ sign followed by the user name.
    – scottkosty
    Aug 1 '15 at 14:50
  • 1
    @DraganPrekrat you can accept answers, but the problem is that currently there is no answer. These are all just "comments". Let's wait a day or two and see if egreg feels like writing an answer. If not, you should write an answer. Although it probably sounds weird to you, it is completely acceptable for you to answer and accept your own answer. However, I think it is polite to wait a bit and let the person who posted the answer in the comments some time to write up the answer him/herself.
    – scottkosty
    Aug 1 '15 at 16:01
2

The package esint provides some types of integrals that are not in the default font. Of course it uses its own shapes, so if you want the Euler ones, you need to disable the loading of esint.

In a normal LaTeX document, just remove \usepackage{esint} (or comment it out). In LyX (which I don't use or recommend), go to Document > Settings > Math Options and set esint to "Do not load".

2
  • 1
    @scottkosky Thanks. Why should one have to disable esint in the first place is beyond my understanding. Loading it in every document is simply wrong.
    – egreg
    Aug 1 '15 at 19:51
  • LyX only loads the esint package if the user inserts a symbol that is associated with that package. For example, if a user inserts the symbol \ointctrclockwise, the package is loaded. I believe that LyX also prefers to use the esint package even for more simple integral signs, such as \int. I'm not sure why we do that.
    – scottkosty
    Aug 1 '15 at 21:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.