4

I just installed LyX on my Windows 10 machine. I have Language Settings > Language > User Interface package set to "Default" (I have also tried English (UK)), package set to "Automatic" and there is \selectlanguage{$$lang} in "Command Start." The spellchecker engine is listed as "Hunspell." I also have en_US.dic, en_US.aff, en_UK.dic, and en_UK.aff installed in Resources > Dict.

When I spellcheck, there are no words in the dictionary. None of the misspellings are highlighted.

Is the Hunspell package installed automatically via the standard installation with LyX? I'm a bit LyX-phobic -- I can't use the LyX command prompt. Is there a package I need to install in MiXTeX? What the -- is going on, lol?

Thanks so much for your help!

  • Do you have the correct path under Tools > Preferences > Paths for "Hunspell dictionaries" ? Note that this is working fine for me on Ubuntu. – scottkosty Aug 1 '15 at 16:06
  • Bingo! Thanks scottkosty. I know it looks like I am dumb and didn't see this earlier, and I apologize. I didn't see the "Path" in the options. I did an hour or so of reading last night. – CPS Aug 1 '15 at 17:22
  • It doesn't look like you're dumb at all. In fact, it would be nice if LyX somehow figured out the path on its own. I think we looked into that but apparently the libraries can be in many different places so it is difficult. – scottkosty Aug 1 '15 at 17:30
  • Did you install MikTeX as well? I'm only asking because this is one of very few questions regarding Windows 10 installs, and somebody in another question is having trouble with TeX Live. If you know MikTeX installation works, that would be great to know. – cfr Aug 2 '15 at 21:22
  • I could not with the above tips, I decided to use the dictionary of libreOffice in: C: \ Program Files \ LibreOffice \ share \ extensions \ dict-en or you can download it from the site itself. – Kelvin Castro Feb 11 at 13:13
6

Thanks Scott! Your answer about changing the Hunspell path in Tools > Preferences > Paths worked for me. I pointed the path to

"C:\Program Files (x86)\MiKTeX 2.9\hunspell\dicts"

Lastly, had to restart Lyx and the spell checking started working.

I tried pointing it to the dict files in the Lyx resources directory ("C:\Program Files (x86)\LyX 2.1\Resources\dicts"), but that didn't work. Mine was a clean install of Lyx 2.1.4 on Windows 10.

Scott, since you're working in the Lyx project, I think you should have them set the default Hunspell path on the Windows install to the correct one, instead of leaving it blank. I just clean installed it a few days ago, so I don't think I touched any of the settings to affect this.

Also note that at least for me, the dict files in the MikTex directory were a few years old, as opposed to the ones in the Lyx resources directory which were much newer.

(Sorry I'm replying this as an answer, but I just joined and I don't have enough reputation to comment.)

3

Set the correct path under Tools > Preferences > Paths for "Hunspell dictionaries".

protected by Community Feb 11 at 15:48

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.