0

I'm having a little difficulty having default variables (with a custom page size) to load properly on the pdf.

I am using the following preamble:

\usepackage{fontspec}

\usepackage{microtype}
\usepackage{adjustbox}
\usepackage{multicol}
\usepackage{lettrine}
\usepackage{changepage}
\usepackage{lipsum}
\usepackage{blindtext}

\usepackage[
  noinfo,
  cam,
  cross,                % crosses as marks
  width=7.25in,         % the width of the galley
  height=8.75in,        % the height of the galley
  center                % actual page is centered on the galley
]{crop}

When I am typing a plain document, the crop marks appear. Unfortunately, the document that I use that has the same preamble but with the problem of everything appearing is a heavily modified and inclusive document with graphics and other sundry bits.

I'm not sure if any of this makes sense, but basically, take away all the graphics and heavy modification, and the crop marks appear. Include heavy modification, and they disappear. Is this making sense?

4
  • Please always post a minimal example for this. You just wrote a little excerpt but it is not compilable. For more information, see wiki.lyx.org/FAQ/MinimalExample.
    – scottkosty
    Aug 1 '15 at 16:01
  • I can't without including an enormous source. I can't replicate it without including some rather large files.
    – Josh N.
    Aug 1 '15 at 21:22
  • The best approach then is a "bisect" approach. Delete half of your document, try to reproduce, if you cannot, then go back and delete the other half. Keep proceding until you get a minimal document. Note that "minimal" does not necessarily mean "small".
    – scottkosty
    Aug 2 '15 at 3:40
  • 1
    I found my solution; it had nothing to do with graphics, but rather my understanding of the crop package. Posted below (hopefully someone will learn from my naiveté).
    – Josh N.
    Aug 4 '15 at 19:26
1

The Solution

I kept digging around searching both XeLaTeX support files and found I completely misunderstood the purpose of the "crop" package.

The "crop" package is designed to place various sundry post-production marks on paper that is larger in size than the actual page of content. My misunderstanding was that in either the geometry package or in LyX's menues my page dimensions (the actual printed page, not the oversized crop package's dimensions) matched each other.

Thus, there was no crop marks because the page size itself was the size of the cropped area.

To Tweak:

  • In LyX: Make sure your page dimensions under Document > Settings... > Page Layout are actually smaller than whatever oversized page you might have for your bleed/crop marks. Then, in your LaTeX Preamble, make sure your settings for page size when using crop are larger than your finished and printed document size.
  • When using LaTeX et al, make sure your geometry is set to be smaller in page dimensions than when you invoke crop in your preamble.

I hope this helps. Document > Settings... > Page Layout LaTeX Preamble section in LyX

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.