since I was moving from MacTeX 2014 to MacTeX 2015, xindy is not able to find any module. Any

texindy -L english -C utf8 animal.idx


Cannot locate xindy module for language english in codepage utf8

Changing language and/or input don't change anything.

I have reinstalled all mactex, and now it works. But why didn't ? the mystery still remains.

However, after a tlmgr update --all, it does not work again.

It seems 1/1, ??:??/??:??] update: xindy [534k] (37078 -> 37716) was at the origin of the problem.

Here is the .idx file I tried

\indexentry{chat!sauvage}{1} \indexentry{chat!domestique}{1} \indexentry{tortue!marine}{1} \indexentry{tortue!terrestre}{1} \indexentry{élèphant!d'Asie}{1} \indexentry{élèphant!d'Afrique}{1} \indexentry{élan!de Sibérie}{1} \indexentry{élan!d'Amérique}{1} \indexentry{chat!sauvage}{2} \indexentry{chat!domestique}{2} \indexentry{tortue!marine}{2} \indexentry{tortue!terrestre}{2} \indexentry{élèphant!d'Asie}{2} \indexentry{élèphant!d'Afrique}{2} \indexentry{élan!de Sibérie}{2} \indexentry{élan!d'Amérique}{2} \indexentry{chat!sauvage}{3} \indexentry{chien!errant}{3}

  • have you tried xindy -M texindy .... instead of texindy – daleif Aug 2 '15 at 13:19
  • same problem... – Maïeul Aug 2 '15 at 13:22
  • Questions: Do you only have MacTeX 2015 installed or did you install it alongside 2014? What does which xindy or which texindy give? What does echo $PATH return? Have you checked the MacTeX preferences in System Preferences to ensure that the 2015 version is properly enabled? Does /usr/texbin exist? If so, what does ls -l /usr/texbin give? Does /usr/local/texlive/2015/bin/*/texindy exist? – cfr Aug 2 '15 at 21:29
  • 1
    I'm voting to close this question as off-topic because it has been solved by a software update – egreg Aug 3 '15 at 9:52
  • 1
    @daleif: Yes on all systems. Yes you are right. – Akira Kakuto Aug 12 '15 at 11:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.