5

Yesterday I installed a clean version of Windows 10 after the update and the format.

Today I was trying install Tex Live but there is an issue. The installer (exe) unzipped the file but then simply shut down when I pressed close and did not start the installation process itself.

The zipped version of the installer (the alternate method cited on the tex live site) opened the CMD successfully, but then a window said that there are some problems with perl and with every press key shut down.

Then I tried with the 2015 live cd, the error is the same as the CMD.

The other programs and drivers are perfect; Tex Live is the only one that caused me trouble.

Is it the same for you or is it just me? Are there some fixes that I can try or I just need to wait for an updated version of the Tex Live suite compatible with Windows 10?

Sorry for the bad English!

  • What about the recommended network install? – Werner Aug 2 '15 at 16:40
  • The network install is not the installer/zip folder (12/16 mb)? I downloaded both and they act like i reported. Then i tried the whole package (the 2015 iso about 2GB) but unsuccessfully... the iso open the CMD (like the zip archive) but then an "alarm" window pop up and the CMD shut down with every key. The only thing thatopen is the installer, but after the autounzip (the process with the green writings) remains still and if i click on close simply shut down not starting the installation process itself. – DrewEugene17 Aug 2 '15 at 16:54
  • 1
    I have Windows 10 and obtained texlive2015 from http://ctan.mirror.rafal.ca/systems/texlive/Images/texlive2015.iso after which I mounted it with ultraiso and ran install-tl-windows.bat in admin mode. TeXLive 2015 installed fine for me. – azetina Aug 3 '15 at 13:15
  • 1
    @daleif here is what I meant ;). I think. – cfr Aug 7 '15 at 22:06
  • 2
    You have to register. Only registered members can post and reply. Remember to register with the email address you are sending from – daleif Aug 9 '15 at 9:31
8

I just tested with a brand-new wx pro 64-bits and an advanced user install and had no problems. To be exact: I downloaded the exe, selected the unpack option and after it finished unpacking I double-clicked install-tl-advanced.bat, but clicking the advanced button also started up the main installer interface.

I searched for this "0xc0000142" error. Unfortunately it seems a pretty intractable beast.

As a workaround, you can try a portable install on a usb stick from another computer.

  • 2
    This is not really an answer, is it? – cfr Aug 4 '15 at 23:00
  • @cfr It is an answer, of course! We know now that you can install without error on Win 10. – Keks Dose Aug 6 '15 at 15:17
  • Ok, I'm going to try with a portable installation from another PC. If I install on the PC MiKTeX and then on the pen drive Tex Live can they go in conflict? – DrewEugene17 Aug 9 '15 at 8:06
2

I stumbled across the same set of errors. The solution to me was, after one day of searching the whole wide interwebs, to

RUN UNDER WINDOWS 7 COMPATIBILTY MODE.

That's it. I have no clue why so ever it does not work with a fresh Windows 10 installation, I am just a plebb, but the compatibility mode worked for me.

-3

Right click either install-tl-advanced.bat or install-tl-windows.bat and select "Run as Administrator".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.