2

I've tried to set the default font size through the documentclass optional parameter but the font size hasn't changed. I'm using xetex with texmaker.

My document:

\documentclass[60pt]{ctexart}
\usepackage[margin=0.5in]{geometry}

\usepackage{graphicx,hhline}
\usepackage{xeCJK}
\setCJKmainfont[16pt]{SimSun}

\begin{document}
\section*{前言}
...

Absolute beginner in Latex - any help would be appreciated!

2
  • 2
    I don't know the ctexart class. For the font size, try such as \setCJKmainfont[Scale=1.6]{SimSun}. Aug 3, 2015 at 9:32
  • @AkiraKakuto When I do that the 8 characters span the width of an A4 page, which is the case whether [Scale=1.6] or [Scale=0.3]. Originally about 45 Chinese characters span a page, which I would like to change it to about 30.
    – M. Shaw
    Aug 3, 2015 at 9:45

1 Answer 1

2

You cannot specify the font size like that as an option for setCJKmainfont. That's what I tried to do as well at first, but then I found this somewhere:

\setCJKmainfont[Scale=1.5]{SimSun}

This uses the main font size (\setmainfont[Scale=...]{font name}) and multiplies its size to get a value for the size of the CJK font.

EDIT:

Note that maybe document classes don't support all font sizes. This might be the reason why the font size didn't change, when you changed that option. In such a case it defaults, usually to 10pt or 11pt, depending on the document class' settings / code.

1
  • Does this change the font for headings too?
    – zyy
    May 7, 2020 at 0:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .