2

I get errors when trying to use the integral math symbol in Lyx document using the report class. I am usig LyX Version 2.1.3. Code and errors below:

#LyX 2.1 created this file. For more info see http://www.lyx.org/
\lyxformat 474
\begin_document
\begin_header
\textclass report
\graphics default
\default_output_format pdf5
\output_sync 0
\bibtex_command default
\index_command default  
\use_package amsmath 2
\use_package amssymb 2
\use_package cancel 0
\use_package esint 1
\use_package mathdots 0
\use_package mathtools 0
\use_package mhchem 0
\use_package stackrel 0
\use_package stmaryrd 0
\use_package undertilde 0
\paperorientation portrait
\suppress_date false
\html_math_output 0
\html_css_as_file 0
\html_be_strict false
\end_header

\begin_body

\begin_layout Standard
\begin_inset Formula $a=\int b$
\end_inset

\end_layout
\end_body
\end_document

The errors I get, when trying to save as PDF, are:

Blockquote! Font \U/esint/m/n/10.95=esint10 at 10.95pt not loadable: metric data not found or bad. relax l.39 \begin{document}

I wasn't able to read the size data for this font, so I will ignore the font specification. [Wizards can fix TFM files using TFtoPL/PLtoTF.] You might try inserting a different font spec; e.g., type `I\font='.

! Font \U/esint/m/n/8=esint10 at 8pt not loadable: metric data not found or bad. relax l.39 \begin{document} I wasn't able to read the size data for this font, so I will ignore the font specification. [Wizards can fix TFM files using TFtoPL/PLtoTF.] You might try inserting a different font spec; e.g., type `I\font='.

! Font \U/esint/m/n/6=esint10 at 6pt not loadable: metric data not found or bad. relax l.39 \begin{document} I wasn't able to read the size data for this font, so I will ignore the font specification. [Wizards can fix TFM files using TFtoPL/PLtoTF.] You might try inserting a different font spec; e.g., type `I\font='.

\c__siunitx_mathtt_int=\count392 ! \textfont6 is undefined (character 1). l.42 $a=\int b$ Somewhere in the math formula just ended, you used the stated character from an undefined font family. For example, plain TeX doesn't allow \it or \sl in subscripts. Proceed, and I'll try to forget that I needed that character.

! \textfont6 is undefined (character 1). l.42 $a=\int b$ Somewhere in the math formula just ended, you used the stated character from an undefined font family. For example, plain TeX doesn't allow \it or \sl in subscripts. Proceed, and I'll try to forget that I needed that character.

Your help would be hugely appreciated as I can't figure this out.

Many thanks.

9
  • I can compile the .lyx file fine on Ubuntu with LyX 2.1.0 and later versions. Something might be missing in your LaTeX installation.
    – scottkosty
    Commented Aug 4, 2015 at 1:01
  • 1
    Please post your minimised example inline here so that it continues to be available for users who might later have the same problem and come across your question. A .lyx file is just plain text. You can copy-paste it, highlight it and hit ctrl+k or use the {} button to format it as code. Also, please paste the error as text. I can't read the screen shot.
    – cfr
    Commented Aug 4, 2015 at 1:02
  • @scottkosty The installation of the package esint is incomplete, apparently.
    – egreg
    Commented Aug 4, 2015 at 6:29
  • @scottkosty I am using LyX Version 2.1.3 in Windows 8, how can I check if there is something missing?
    – Ella Jay
    Commented Aug 4, 2015 at 12:54
  • @cfr I did this. I tried to condence it as much as possible. I'm really no expert and also in a great hurry (writing my PhD thesis). There are quite a few errors which I don't have time to copy paste (there seems no quick way to do all at once?) but hopefully with the code I added one might be able to help me.
    – Ella Jay
    Commented Aug 4, 2015 at 12:55

1 Answer 1

2

There are two choices: 1) install esint.sty (precise method depends on which LaTeX distro one uses); or 2) in LyX go to Document -> Settings... -> Math Options and uncheck "Use esint package automatically". This option will only work if you are not using any of the 'advanced' integral signs that esint provides (double integrals, path integrals, etc.), but it works fine for using basic integrals.

1
  • Indeed: Not loading the esint package did the trick. The first method did not. I verified in MiKTeX that esint was installed, reinstalled it and reconfigured Lyx, but that did not fix the problem. Commented Oct 17, 2015 at 16:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .