5

I just upgraded to Lyx 2.1.4 from Lyx 2.1.3 and the spellchecker does not work -- it asks if I want to start from the beginning and then closes like it found no errors. I am using Windows 7 with a clean default install of Lyx. Any ideas on how to get the spellchecker working again?

  • Note that I tried the fix suggested for "LyX Install Not Recognizing Installed Spellcheck Dictionaries" and it did not work. – user1930565 Aug 4 '15 at 11:48
  • As an interim fix I rolled back to Lyx 2.1.3, which works as expected. – user1930565 Aug 4 '15 at 18:27
  • Are your preferences the same? You might try taking the preferences file from 2.1.3 that works for you and using it with 2.1.4 to see if that helps. To find your pfreferences file, go to Help About. It is in the user dir. On Ubuntu this is in ~/.lyx but I don't know about Windows. – scottkosty Aug 5 '15 at 3:48
5

I think I found the problem. First point the path of hunspell to your equivalent folder:

C:\Program Files (x86)\LyX 2.1\Resources\dicts

Then, it is an incorrect or corrupted en_US.aff/dic files. I downloaded another version from hunspell project:

http://sourceforge.net/projects/hunspell/files/Spelling%20dictionaries/en_US/

and overwrite ir in the dicts folder, that worked for me.

  • Worked for me. I had to replace the files. (You also have to remember to 'reconfigure' from the tools menu. – Veridian Oct 13 '15 at 18:36
  • I tried all other comments (paths were empty) but in the end also needed to reinstall the dictionary files from the location mentioned. I was surprised by this. Does the LyX installation have corrupted files in it? – Pete P May 10 '16 at 19:39
6

I had a similar problem which I managed to fix by going into Document -> Settings -> Language and then changing the default, which was English, to English (UK).

2

The UK solution works, but if you want any other language like US English, this is the way to fix it:

First, find the hunspell directory with all the dictionary (dic and aff) files in it. For me, it was "C:\Program Files (x86)\MiKTeX 2.9\hunspell\dicts"

Next, point Tools > Preferences > Paths > Hunspell Dictionaries text box to this directory.

Lastly, restart Lyx.

Source: LyX Install Not Recognizing Installed Spellcheck Dictionaries

  • I tried that before I posted the question and it did not work for me. – user1930565 Aug 20 '15 at 8:39
  • I think you need to reconfigure – Veridian Oct 13 '15 at 18:36
0

I was able to find a solution to this problem. Copy your dic and aff files from where they are now (C:\Program Files (x86)\LyX 2.1\Resources\dicts, usually), to a new folder, C:\dicts (or similar), and then change the path in lyx accordingly, and reconfigure lyx.

I don't know exactly why this works though.

  • This did not work for me. – user1930565 Aug 7 '15 at 15:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.