3

So, I am getting this error yet again, I can't figure out what I did before on another system (same .tex file) that worked.

Using TeXStudio 2.9.4.

I have babel-spanish installed. I tried deleting .aux file and recompiling, same error.

My file is basically:

...
\usepackage[spanish]{babel}
...
\selectlanguage{spanish}
...
\begin{document}
...
\end{document}

Any help is greatly appreciated, I'm going bald(er) in exasperation.

closed as off-topic by egreg, user31729, Jesse, Martin Schröder, user13907 Aug 5 '15 at 8:34

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Check the error message in the .log file, which line number and file is reported? Then you have more context to provide a real, complete but minimal example for reproducing the problem. – Heiko Oberdiek Aug 5 '15 at 0:51
  • This? ! Package babel Error: You haven't loaded the option spanish yet. l.30 \select@language{spanish} ! Package babel Error: You haven't loaded the option spanish yet. l.37 \select@language{spanish} You may proceed, but expect unexpected results – So Many Goblins Aug 5 '15 at 0:57
  • 1
    When TeX opens a file it adds an open parenthesis with the file name in the .log file. When TeX has finished reading, it adds the closing parenthesis. This can be used to identify the file. Also you can see in the .log file, whether package babel with which languages is loaded. – Heiko Oberdiek Aug 5 '15 at 1:05
  • 4
    I'm voting to close this question as off-topic because the issue was solved with a software update – egreg Aug 5 '15 at 7:53
  • This was not a software update (nothing to do with miktex, texstudio or whatever), it was a package update which had to be done manually, but suit yourself, I'm sure this will never ever happen to anyone else (like it happened to me on two separate installs) and this thread is thus useless. – So Many Goblins Aug 5 '15 at 12:27
1

OK, hopefully this will help someone, as I got this error multiple times in the past. The problem seems to be that the Babel package was outdated. Weird thing is, it's the one that comes bundled with TexStudio (MikTex 2.9) and going to the package manager showed that the available packaged version was from 2013, the outdated version... Synchronization did nothing. Solved it by going to repository -> change package repository, and picking a new mirror.

Not the answer you're looking for? Browse other questions tagged or ask your own question.