2

I've just noticed, that after rendering if I zoom the text then it look like a low quality text (look at the screen). I've heard that I can install cm-super package. I put \usepackage{cm-super} to the preamble but get an error "cm-super.sty not found". Before If I didn't have any package latex suggested me to install it right in the latex so I didn't have to visit any websites or something. Am I supposed to install it manually? Anyway, how can I solve the problem? I have two files in my project: latex file and .sty file. Here's how the preambles look:

  1. In the main file:

    \documentclass[10pt, a4paper]{article}
    \usepackage[utf8]{inputenc}
    \usepackage[T2A]{fontenc}
    \usepackage[english, russian]{babel}
    \usepackage{Lections_style}
    
    1. In the lections style:

        \RequirePackage{amsfonts}
        \RequirePackage{amsmath}
        \RequirePackage{amssymb}
        \RequirePackage{graphicx}
        \RequirePackage{babel,blindtext}
        \RequirePackage{subfigure}
        \RequirePackage{hyperref}
        \RequirePackage{fancyhdr}
        \RequirePackage{cite}
        \RequirePackage{amsthm}
        \RequirePackage{xparse}
        \RequirePackage{mathabx}
        \RequirePackage{array}
        \RequirePackage{tabularx}
        \RequirePackage{multirow}
        \RequirePackage{makecell}
      

There're already 55 pages typed so I would be very glad if there's any solution without a lot of pain. Thank you and sorry for my English.

I've been asked to give a MWE, so here it is:

   \documentclass[10pt, a4paper]{article} 
   \usepackage[utf8]{inputenc} 
    \usepackage[T2A]{fontenc} 
    \usepackage[english, russian]{babel} 
    \begin{document} Проверка текста. 
    \end{document}

enter image description here

  • Clearly, you don't have a cyrillic font in true type or type 1 format that pdflatex is aware of. As for mathabx, do you have mathabx-type1 installed? – Bernard Aug 5 '15 at 12:28
  • @LaRiFaRi what is MWE, sorry? – MGMKLML Aug 5 '15 at 12:31
  • @Bernard I didn't understand you. Could you explain? – MGMKLML Aug 5 '15 at 12:31
  • That is a minimal working example (MWE) – LaRiFaRi Aug 5 '15 at 12:32
  • @LaRiFaRi I've just updated it to the main post, watch – MGMKLML Aug 5 '15 at 12:33
1

From the start menu launch MiKTeX Package Manager, select mathabx-type1, right-click on the selection and select install. base.

To install cm-super, do the same from MPM.

Finally run from the command-line: updmap --verbose to update the type 1 fonts database.

enter image description here

Added: I forgot this (important) detail: for the mathabx fonts to be displayed with their type 1 versions, as there is no .fd file, add this to your preamble:

 \DeclareFontShape{U}{matha}{m}{n}{
 <-6> matha5 <6-7> matha6 <7-8> matha7
 <8-9> matha8 <9-10> matha9
 <10-12> matha10 <12-> matha12
 }{}

and do the same for mathb and mathx if you want to use them.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.