I'm using \fullcite to produce in-margin-note citations as per my older question. I've almost got the behavior I want, but biblatex's \fullcite command inserts a leading indent before the citation starts:

example of space in weird place

I'm using the numeric biblatex style. It's hard to generate a minimal example that generates this text because it relies on a recent version of tufte-latex, but refer to tufte-latex Issue 60.

  • 3
    You might have to provide a minimal example as it's not clear here if you are using the vanilla \fullcite. If you are using some sort of bibliography environment for the citations to do this, they you have to look at \bibhang etc. which are used to move indents and margins around when printing bibliography items. – PLK Aug 17 '11 at 10:17
  • 2
    @Alterscape I agree with PLK. I've tried this using the tufte-book class revisions and vanilla \fullcite. I don't get the indent. – Audrey Aug 17 '11 at 13:35
  • @Audrey and PLK: I've gone through the modifications to my document and worked out what the cause is, but I don't know the fix. I'm editing my question to incorporate the new info. – Alterscape Aug 18 '11 at 16:35

Okay, so the answer involves my misinterpretations of how the \AtEveryCiteKey definition works. I had the following markup in my document, which I had formatted to be clear (to my C/Java/Ruby-writing programmer's mind) with newlines and indents:


LaTeX was interpreting the newlines as whitespace separated by (non-printing) characters, and adding four spaces to the beginning of every \fullcite!

I changed the markup to:


And now all is well.

  • 3
    To avoid very long lines, you can end each line in your first code excerpt with the percent sign. – Audrey Aug 18 '11 at 17:00
  • 6
    It's not the leading tabs that TeX is pick up: it ignores leading whitespace. It's the newlines, which TeX is interpreting as spaces. – Seamus Aug 18 '11 at 17:05
  • Many thanks for that, @Alterscape - I just bumped into the same problem, and solved it thanks to your posting. Just wanted to note, I was working with the code as in this post; and discovered I have indents due to spaces both before and after the \parseMyNum call there (but in my case, from \newbibmacro*); which had to look like ^\parseMyNum{#1}% (all spaces removed), before all indentation would disappear! Furthermore, none of the other commands seem to be so sensitive to whitespace?! Therefore, thanks again - and cheers! – sdaau May 23 '12 at 22:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.