0

I am running MikTex 2.9 on Windows 8 and i am trying to compile my first .tex file. I face the following error when i try to build latex->PS or latex->PDF.

latex> latex.exe: The memory dump file could not be found
latex> latex.exe: Data: latex.fmt
BibTex> I couldn't open file name 'prac.aux'

I have checked that the directories are correct and i have ghostscript viewer and adobe reader for PS and PDF formats respectively. I tried other solutions such as 'Run as administrator' and initexmf --dump but it didn't work. I also tried reinstalling MikTex 2.9 but to no avail.

I then tried to go to Start => Programs => MiKTeX 2.9 => Maintenance => Settings and Update Formats as suggested in some solutions but i faced the following error:

'The MikTex configuration utility failed. Do you want to see the transcript?'

If I click 'Yes', then a new windows appears with lot of text. I have pasted few top lines below. Any help would be appreciated. Thanks

Creating the latex format file...
Running miktex-pdftex.exe...
This is pdfTeX, Version 3.14159265-2.6-1.40.16 (MiKTeX 2.9 64-bit) (INITEX)
entering extended mode
("C:\Program Files\MiKTeX 2.9\tex\latex\config\latex.ini"
(C:\Users\lenovo\AppData\Roaming\MiKTeX\2.9\tex\generic
\config\pdftexconfig.tex
)
("C:\Program Files\MiKTeX 2.9\tex\latex\base\latex.ltx"
("C:\Program Files\MiKTeX 2.9\tex\latex\00miktex\texsys.cfg")
./texsys.aux found     

\@currdir set to: ./.

Assuming \openin and \input 

have the same search path.


Defining UNIX/DOS style filename parser.

catcodes, registers, compatibility for TeX 2,  parameters,

LaTeX2e <2015/01/01> patch level 2

hacks, control, par, spacing, files, font encodings, lengths,

====================================

Local config file fonttext.cfg used

====================================

("C:\Program Files\MiKTeX 2.9\tex\latex\00miktex\fonttext.cfg"

("C:\Program Files\MiKTeX 2.9\tex\latex\base\fonttext.ltx"

=== Don't modify this file, use a .cfg file instead ===

("C:\Program Files\MiKTeX 2.9\tex\latex\base\omlenc.def")

("C:\Program Files\MiKTeX 2.9\tex\latex\base\t1enc.def")

("C:\Program Files\MiKTeX 2.9\tex\latex\base\ot1enc.def")

("C:\Program Files\MiKTeX 2.9\tex\latex\base\omsenc.def")

("C:\Program Files\MiKTeX 2.9\tex\latex\base\t1cmr.fd")

("C:\Program Files\MiKTeX 2.9\tex\latex\base\ot1cmr.fd")

("C:\Program Files\MiKTeX 2.9\tex\latex\base\ot1cmss.fd")

("C:\Program Files\MiKTeX 2.9\tex\latex\base\ot1cmtt.fd")))

====================================

Local config file fontmath.cfg used

====================================

("C:\Program Files\MiKTeX 2.9\tex\latex\00miktex\fontmath.cfg"

("C:\Program Files\MiKTeX 2.9\tex\latex\base\fontmath.ltx"

=== Don't modify this file, use a .cfg file instead ===

("C:\Program Files\MiKTeX 2.9\tex\latex\base\omlcmm.fd")    

("C:\Program Files\MiKTeX 2.9\tex\latex\base\omscmsy.fd")

("C:\Program Files\MiKTeX 2.9\tex\latex\base\omxcmex.fd")

("C:\Program Files\MiKTeX 2.9\tex\latex\base\ucmr.fd")))

====================================

Local config file preload.cfg used

=====================================

("C:\Program Files\MiKTeX 2.9\tex\latex\base\preload.cfg"

("C:\Program Files\MiKTeX 2.9\tex\latex\base\preload.ltx")) page nos., x-ref,
environments, center, verbatim, math definitions, boxes, title, sectioning,

contents, floats, footnotes, index, bibliography, output,

===========================================

Local configuration file hyphen.cfg used

===========================================

("C:\Program Files\MiKTeX 2.9\tex\cslatex\base\hyphen.cfg"

Loading english hyphenation patterns and exceptions

("C:\Program Files\MiKTeX 2.9\tex\generic\hyphen\hyphen.tex")

! LaTeX Error: Encoding scheme `IL2' unknown.

See the LaTeX manual or LaTeX Companion for explanation.

Type  H <return>  for immediate help.

 ...                                              



l.131 ...                        \@requesthyphens}

No pages of output.

Transcript written on latex.log.

miktex-makefmt: miktex-pdftex.exe failed on latex.ini.    
initexmf.EXE: The operation failed for some reason.
initexmf.EXE: Data: C:\Program Files\MiKTeX 2.9\miktex\bin\x64\miktex-    makefmt.exe
12
  • You will have to show more lines. The error is somewhere below. – Ulrike Fischer Aug 6 '15 at 13:21
  • i added all the text in that transcript – Newbie Aug 6 '15 at 13:27
  • Looks like you got the broken babel package - it was for a short time available and you seem to have install miktex just then. Run an update with the package manager (admin). – Ulrike Fischer Aug 6 '15 at 14:02
  • @UlrikeFischer Do you mean to synchronize in package manager (admin)? – Newbie Aug 6 '15 at 14:10
  • Sorry I meant the update manager (admin). But you can also use the package manager to deinstall and reinstall babel. Whatever gets rid of the faulty version is fine. – Ulrike Fischer Aug 6 '15 at 14:12
2

There is currently a bug in the babel package from miktex. The files are in tex/tex/generic/babel instead of tex/generic/babel.

This is a problem if the cslatex package is installed as now its hyphen.cfg is found before the hyphen.cfg from babel.

Until the package is repaired you can do the following:

  1. Move the hyphen.cfg from tex/tex/generic/babel to tex/generic/babel.

  2. Refresh the FNDB in miktex settings (admin)

  3. Update the formats.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.